Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

internal server error

By
dinov
on 12/26/13, 5:18 AM 2,268 views

I am using a Windows 8 as OS, after installing Openerp 7, a receive this message. Can some one help me to solve this probleme ?

Internal Server Error

{"message": "OpenERP Server Error", "code": 200, "data": {"debug": "Server Traceback (most recent call last):\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\session.py\", line 89, in send\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\.\openerp\netsvc.py\", line 292, in dispatch_rpc\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\.\openerp\service\web_services.py\", line 122, in dispatch\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\.\openerp\service\web_services.py\", line 359, in exp_list\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\.\openerp\sql_db.py\", line 484, in cursor\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\.\openerp\sql_db.py\", line 182, in __init__\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\.\openerp\sql_db.py\", line 377, in _locked\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\.\openerp\sql_db.py\", line 440, in borrow\n File \"psycopg2\__init__.pyc\", line 178, in connect\nOperationalError: could not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (::1) and accepting\n\tTCP/IP connections on port 5432?\ncould not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (127.0.0.1) and accepting\n\tTCP/IP connections on port 5432?\n\n\nClient Traceback (most recent call last):\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\http.py\", line 285, in dispatch\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\controllers\main.py\", line 573, in index\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\controllers\main.py\", line 98, in db_monodb_redirect\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\controllers\main.py\", line 109, in db_redirect\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\controllers\main.py\", line 90, in db_list\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\session.py\", line 30, in proxy_method\n File \"C:\Program Files (x86)\OpenERP 7.0-20131219-002442\Server\server\openerp\addons\web\session.py\", line 103, in send\nFault: <fault could="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\n\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (::1)="" and="" accepting\n\ttcp="" ip="" connections="" on="" port="" 5432?\ncould="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\n\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (127.0.0.1)="" and="" accepting\n\ttcp="" ip="" connections="" on="" port="" 5432?\n:="" 'traceback="" (most="" recent="" call="" last):\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\openerp\\\\addons\\\\web\\\\session.py\",="" line="" 89,="" in="" send\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\.\\\\openerp\\\\netsvc.py\",="" line="" 292,="" in="" dispatch_rpc\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\.\\\\openerp\\\\service\\\\web_services.py\",="" line="" 122,="" in="" dispatch\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\.\\\\openerp\\\\service\\\\web_services.py\",="" line="" 359,="" in="" exp_list\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 484,="" in="" cursor\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 182,="" in="" __init__\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 377,="" in="" _locked\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20131219-002442\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 440,="" in="" borrow\\n="" file="" \"psycopg2\\\\__init__.pyc\",="" line="" 178,="" in="" connect\\noperationalerror:="" could="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\\n\\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (::1)="" and="" accepting\\n\\ttcp="" ip="" connections="" on="" port="" 5432?\\ncould="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\\n\\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (127.0.0.1)="" and="" accepting\\n\\ttcp="" ip="" connections="" on="" port="" 5432?\\n\\n'="">\n", "fault_code": "could not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (::1) and accepting\n\tTCP/IP connections on port 5432?\ncould not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (127.0.0.1) and accepting\n\tTCP/IP connections on port 5432?\n", "type": "server_exception"}}

0

Gustavo

--Gustavo--
950
| 2 1 4
Buenos Aires, Argentina
--Gustavo--

Python developer, big fan of sailing

Gustavo
On 12/26/13, 8:39 AM

You have problems connecting to your PostgreSQL database. Try connecting from the command line with the psql utility, or creating a database with the createdb command. You have to run these commands as the openerp user

0
ASP
On 12/26/13, 8:33 AM

Hi Dinov,

Seems like your postgresql has not been installed properly or corrupted as 5432 is the default PORT for postgresql to listen.

This may be helpful, please have a look :

https://accounts.openerp.com/forum/Help-1/question/23644/

Also you can try re-installing the application, but install postgresql separately and test, then go for openerp 7.0 set up.

Cheers

:)

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 12/26/13, 5:18 AM
Seen: 2268 times
Last updated: 3/16/15, 8:10 AM