Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Internal Error on Invoice Validation

on 10/10/13, 8:33 AM 2,698 views

Hello everyone,

I'm having a big trouble with our OpenERP7. The ERP software was installed to our company by an external person. Right now that person doesn't work with us anymore and I have to take care of the ERP. Today we found that we can't Validate the Draft Invoices. Once you click to the Validate button we get the following error, and I don't know what is wrong, looks like something about the database but I have no idea.

OpenERP Server Error

Client Traceback (most recent call last): File "C:\app\Server\server\openerp\addons\web\http.py", line 204, in dispatch File "C:\app\Server\server\openerp\addons\web\controllers\main.py", line 1132, in exec_workflow File "C:\app\Server\server\openerp\addons\web\session.py", line 147, in exec_workflow File "C:\app\Server\server\openerp\addons\web\session.py", line 30, in proxy_method File "C:\app\Server\server\openerp\addons\web\session.py", line 103, in send

Server Traceback (most recent call last): File "C:\app\Server\server\openerp\addons\web\session.py", line 89, in send File "C:\app\Server\server.\openerp\netsvc.py", line 292, in dispatch_rpc File "C:\app\Server\server.\openerp\service\web_services.py", line 626, in dispatch File "C:\app\Server\server.\openerp\osv\osv.py", line 131, in wrapper File "C:\app\Server\server.\openerp\osv\osv.py", line 220, in exec_workflow File "C:\app\Server\server.\openerp\osv\osv.py", line 213, in exec_workflow_cr File "C:\app\Server\server.\openerp\osv\orm.py", line 3926, in _workflow_signal File "C:\app\Server\server.\openerp\workflow\wkf_service.py", line 119, in trg_validate File "C:\app\Server\server.\openerp\workflow\instance.py", line 43, in validate File "C:\app\Server\server.\openerp\workflow\workitem.py", line 60, in process File "C:\app\Server\server.\openerp\workflow\workitem.py", line 175, in _split_test File "C:\app\Server\server.\openerp\workflow\workitem.py", line 183, in _join_test File "C:\app\Server\server.\openerp\workflow\workitem.py", line 40, in create File "C:\app\Server\server.\openerp\workflow\workitem.py", line 52, in process File "C:\app\Server\server.\openerp\workflow\workitem.py", line 106, in _execute File "C:\app\Server\server.\openerp\workflow\wkf_expr.py", line 67, in execute File "C:\app\Server\server.\openerp\workflow\wkf_expr.py", line 57, in _eval_expr File "C:\app\Server\server.\openerp\tools\safe_eval.py", line 241, in safe_eval File "", line 1, in <module> File "C:\app\Server\server.\openerp\osv\orm.py", line 374, in function_proxy File "C:\app\Server\server\openerp\addons\account\account_invoice.py", line 1029, in action_move_create
File "C:\app\Server\server\openerp\addons\account\account.py", line 1422, in create File "C:\app\Server\server.\openerp\osv\orm.py", line 4469, in create File "C:\app\Server\server.\openerp\osv\fields.py", line 557, in set File "C:\app\Server\server\openerp\addons\account\account_move_line.py", line 1226, in create File "C:\app\Server\server.\openerp\osv\orm.py", line 4434, in create File "C:\app\Server\server.\openerp\sql_db.py", line 161, in wrapper File "C:\app\Server\server.\openerp\sql_db.py", line 226, in execute InternalError: no se pudo leer el bloque 2 del archivo «base/16393/21728»: se leyeron sólo 0 de 8192 bytes

Did you restart the server?

on 10/10/13, 1:16 PM

Yes, and I get the same...

on 10/10/13, 2:14 PM

Restart the postgresql server/service as well.

on 10/10/13, 2:29 PM

I restarted right now only the postgresql service and we are getting the same error

on 10/10/13, 2:58 PM


| 4 5 8
Tétouan, Morocco

For more informations about IBS, please visit our website at www.ibs-na.com.

For a specific questions, collaboration or help, please send us an email to support@ibs-na.com

On 10/10/13, 3:59 PM

This appears to be a postgresql database issue and not an OpenERP one, check this link: http://stackoverflow.com/questions/6895736/error-could-not-read-block-4707-of-relation-1663-16384-16564-success

You need to check your database and research how to fix corrupted data in postgersql databases.

The Postgresql error you should be researching starts with could not read block, in your case it's in another language.

Thank you very much for your help! I restored the base/16393/21728 files from a backup and seems that we have fixed it. Thanks again for your answers

on 10/11/13, 5:15 AM

You are welcome :-)

on 10/11/13, 7:09 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 10/10/13, 8:33 AM
Seen: 2698 times
Last updated: 3/16/15, 8:10 AM