Odoo Help


Internal domain name visible to Google when sync is activated

Roma Film
on 7/2/15, 11:51 AM 3,403 views

I have a problem with the synchronization of calendar with Google. I have an Ubuntu server on a local LAN that is running Odoo. I access Odoo in LAN through url


And so far so good. Then I created a DynDNS domain and activated DNSS on my router to access it from the outside. I access it as


It works perfectly. So I followed the instructions to synchronize the calendar with Google. I created the two values ​​required, Google Client ID and Client Secret Google, and I made sure they were well written without spaces or other garbage, and I enabled on the corresponding Google project the Google+ and Calendar APIs. I verified I did all correctly several times.

However, when I try to sync calendars, I get the following error:

400. That's an error. 
Error: invalid_request 
Invalid parameter value for redirect_uri: Non-public domains not allowed:

However if I'm going to see the request, I get:

scope = https://www.googleapis.com/auth/calendar
response_type code =
redirect_uri = http://w3.mydomain.lan/google_account/authentication
access_type = offline
approval_prompt = force
state = {"s": "calendar", "d", "MioDominioERP", "f", "mydomain.office-on-the.net:8069/web#vi...nu_id=360&action=413"}
client_id = xxx...xxx.apps.googleusercontent.com

Why Google is able to see the internal domain name???

PS Obviously I specified redirect_uri in the Google project as


Thank you in advance.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 7/2/15, 11:51 AM
Seen: 3403 times
Last updated: 7/2/15, 11:52 AM