Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Installing OpenOffice Report Designer

AppliSential (Pty) Ltd
on 6/12/13, 6:42 AM 7,467 views

I am trying to install the Report Designer module, I have loaded the module into the addons folder of openerp. When installing via the web interface, the install starts but then does not proceed and the install button changes to "Cancel Install". Looking at the Technical Data tab status shows "To be installed" and never progresses past this.

I assume for some reason the process has stalled, is there anyway I can check what is the cause of this problem?




--Borni DHIFI--
| 6 8 9
Tunis, Tunisia
--Borni DHIFI--

Techno Functional Consultant Odoo(OpenERP) 


Skype : dhifi.borni

On 6/12/13, 6:49 AM


module base_report_designer already exists in your Apps Settings>>Modules>>Apps . So just install the module and do not download another version.

Borni is right, also: don't forget to install the plugin. After you install the module go to: Reporting --> Settings --> Report Designer. You can download the plugin here, and see the instructions to install it under OO.

on 6/12/13, 6:53 AM
Peter Wismer
On 11/30/14, 6:24 AM

I have the same experience as AppliSential. I get an ODOO warning: duplicate key value violates unique constraint "ir_model_data_pkey"

DETAIL: Key(id)=(37814) already exists.

It seems that the installation package have fixed id s when making entries in ir_model_data.

Anybody who knows what to do?



Thanks guys. I am installing module base_report_designer, this is the one that gets stuck during install. I can cancel and install again with the same result. @Suresh, I am not able to get the module installed so there is no Report Designer menu option yet.

Is there some log file that I could view to see why it is stuck? The openerp-server.log file does not show anything unfortunately.

so if you downloaded other module delete this module in apps and install again base_report_designer if the same result create a new database to test it .

on 6/12/13, 7:26 AM

Did you have any issues installing other modules? Have you tried updating your module list? If the module doesn't finish installing, you can choose to uninstall it - or go to your addons directory, and delete the ".pyc" files. (only under that module) Then restart your server, and try again.

on 6/12/13, 7:27 AM

I have installed other modules and updated my module list. I dont have an option to uninstall, only to cancel install. If I delete the the pyc files will I need to update module list or how will I get the option to install this module again?

AppliSential (Pty) Ltd
on 6/12/13, 7:37 AM

Cancelling the installation is effectively the same. Cancel it. Restart server, upate module list; try again.

on 6/12/13, 9:00 AM

Tried that - no dice unfortunately. :(

AppliSential (Pty) Ltd
on 6/12/13, 9:02 AM

Okay, try deleting all report_designer modules from your addon directory. Update your module list, search for it in your module list. Not there? Good. Now go to: https://github.com/agb80/ocb-addons/tree/master/base_report_designer. Download this file, add it to your module list - restart the server, update module list and try again.

on 6/12/13, 9:05 AM

Uploaded the git module to the addons folder, updated the module list - now the base_report_designer does not even appear as a module to install. The folder is definitely there when browsing the path and the permissions are set the same as the other modules in the addon folder.

AppliSential (Pty) Ltd
on 6/12/13, 1:12 PM

You are using v7 right? Because the module is for v7, otherwise I'll link you another one. Are you sure you can install or update other modules? May be something more than just this specific module.

on 6/12/13, 1:26 PM

Im am using V7, managed to get the module for installation to showup again by running a DB upgrade. Logged into ERP again, I can see the module - clicking install still just changes "Install" to "Cancel Install" and just gets stuck again as per original post. Seems all my modules get stuck in the same way Report Designer does - any ideas?

AppliSential (Pty) Ltd
on 6/13/13, 8:38 AM

skype : dhifi.borni

on 6/13/13, 10:00 AM

If all your modules get stuck the same way, it's obviously not related to that specific module. I think it's best you start fresh. You can make a data backup and restore when you have reinstalled your OpenERP installation.

Ubuntu install (recommended): http://www.theopensourcerer.com/2012/12/how-to-install-openerp-7-0-on-ubuntu-12-04-lts/ Windows install: http://www.baconconsult.eu/home/our-products/openerp/openerp-7-0-installation

on 6/14/13, 9:28 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 6/12/13, 6:42 AM
Seen: 7467 times
Last updated: 3/16/15, 8:10 AM