Odoo Help

0

Installing BeautifulSoup for Account_banking module

By
Guillaume Pays
on 4/11/13, 3:37 PM 3,655 views

Hello,

I'm having issues installing this module even though I think I've read all posts on the net about it!! :)

I've especially followed this tutorial: w w w .stat.ucla.edu/~rosario/classes/07F/202a/python/

And done the following: 1/ Python 2.7 installation 2/ easy_install installation, with the path created in "Environment variables" 3/ beautifulsoup4 install with same result as in the tutorial

However when I want to install Account_banking module from OpenERP "Installed modules" then I always get this error:

Error Unable to install module "account_banking" because an external dependency is not met: No module named BeautifulSoup

I have tried several things, even downloading beautifulsoup.py and copying it in Openerp folder but it didn't help either.

Any ideas why it doesn't work??

Thanks! G.

0
ton123
On 4/11/13, 5:10 PM

Download BeautifulSoup 3.2.1.tar.gz. wget http://www.crummy.com/software/Beautifu ... 2.1.tar.gz If you go to your drive you can see here BeautifulSoup-3.2.1.tar

extract: tar -xvf BeautifulSoup-3.2.1.tar

Copy to the right directory (in my case, for you it can be different)

cp /volume1/the place you have put it/BeautifulSoup-3.2.1/BeautifulSoup.py /volume1/@appstore/P ython/usr/lib/python2.7/BeautifulSoup.py

To give more certainty it is best to stop and start your server again.

Thats it. If you did this wrong you get error messages when you install the account_banking module.

Oops sorry for the reply meant to be a comment. I have also restarted the server and it did not help. I have no clue why BeautifulSoup cannot be found by OpenERP but this is pretty annoying since I cannot install this banking module and cannot use SEPA export... If you can think of anything else to fix this issue that would be much appreciated.

Unfortunately I thought the previous install worked as the status went to "to be installed" but this status remained even though I hit "Apply Scheduled upgrades". I used the modules versions Trunk and 6.1, I'm on win7 and I use OpenERP 7.0

Guillaume Pays
on 4/18/13, 11:40 AM

@Guillaume Pays: If my answer is the answer on your question I appreciate if you marked it as answered. If you find my answer is useful and interesting for others you can best vote it up.

ton123
on 4/22/13, 7:14 AM

Thanks a lot for your help! I stopped using openerp on windows and installed it on Ubuntu. BeautifulSoup got then installed very easily indeed

Guillaume Pays
on 4/22/13, 10:56 AM
0
Guillaume Pays
On 4/18/13, 7:07 AM

Hi, I actually still have this issue. BeautifulSoup is installed for sure in the right directory but Openerp still cannot find it. I followed this process h t t p ://forum.openerp.com/forum/topic36224.html but it didn't work either.

Beautifulsoup.py is in this directory: C:\Python27\Lib\site-packages

Any idea???

Thanks!!

It is not OK to repeat your question this way. This is reserved for answers. In the comment on my answer you said it was ok ... And here you said it is not ok? It is better to make a new comment on my answer. I have added: To give more certainty it is best to stop and start your server again.

ton123
on 4/18/13, 10:48 AM
0
Mark Teunissen
On 9/10/13, 7:47 PM

Hello, I have a (dutch) description for installing Python 2.7, BeautifulSoup 3.2.1 and the module account_banking for OE 7.0 under MS Windows, with a bypass to avoid the error in OE 7.0 Although there wil be a new problem in opening a POS session... If interested, send me a mail.

Regards,

Mark (mte@entric.nl)

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 4/11/13, 3:37 PM
Seen: 3655 times
Last updated: 3/16/15, 8:10 AM