Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

In custom module top menu item is hidden for user other than admin.

By
Deepak nayak
on 12/13/13, 7:46 AM 5,623 views

I created a custom module.When I login with admin credential than my top menu is visible to me.But when I login with other user than Top menu become invisible.I don't know what is happening.Can someone please guide me how to resolve this problem.

Thankyou in advance for your support.

Check that you have not added an admin group to the top menu (group=base.system_admin somethhing like that). If you have not try and give access to the employees under security access.

kaynis
on 12/13/13, 8:50 AM

Hi kayris, Thank for reply.I done the same what you suggest but In my case I have only one module installed in OpenERP . When I login with administrator its showing two top menu which is(My custom module menu and the Setting Menu).After that I created one new user, given access right only for my custom module.When I login with new user.I am not able to see Top menu. How I resolve this error.Please suggest me...Thank u

Deepak nayak
on 12/13/13, 9:49 AM

In your settings, go to Users Settings and give the new user you created configuration access and try logging in with this user after that. If the user sees the Top menu then you need to go to access right and ensure that the user you have created is in right group. See also below what Grover Menacho wrote and add the group="base.group_user" to your code. This will make every user have access to your module automatically.

kaynis
on 12/13/13, 10:41 AM
2

Grover Menacho

--Grover Menacho--
2523
| 5 7 8
La Paz, Bolivia
--Grover Menacho--

Systems Engineer + MBA

Grover Menacho
On 12/13/13, 9:49 AM

You have to add which groups can see the menu:

For example:

<menuitem name="Messaging"
      id="mail.mail_feeds_main"
      groups="base.group_user"
      sequence="10"/>

So you have to set groups on your menuitem.

Hi Grover,Thank You For your reply.I implemented the same which you mention.My problem is different.Actually what I want is, Other than administrator No one she Setting tab. What I done is I creates one custom module and installed in blank database.Giving group access to the top menuitem like you mention.When I login with administrator I see Both My custom module top menu and Setting top menu . After that I created a new User and given only my module access.When I login with this user I am Not able to see any top

Deepak nayak
on 12/14/13, 8:06 AM

menu.But when I give administrator access like(Access Right) and My module access to the new user.I am able to see both the top menu when I login with new user. Will you please give me some suggestion now How I will hide Setting top menu for other user while showing only one top menu which is my custom top menu. Thank you in advance for your suggestion.

Deepak nayak
on 12/14/13, 8:27 AM

Please post your XML code and I'll suggest you something. Maybe I'm missing something

GH Mediacloud, Grover Menacho
on 12/15/13, 8:59 PM

Inherit your group from "Administration/Settings". If groups are created through .xml use it like or by .csv then add a column named 'implied_ids/id' and value for that column is base.group_system.

Ubaid
on 1/13/16, 4:26 AM

*If groups are created through .xml use it like: "".

Ubaid
on 1/13/16, 4:29 AM
0
Phillip
On 6/23/15, 9:24 PM

As Administrator Create a New Group 

-Ensure Group has access to ALL the MENUS you want

-Ensure Group has permissions to all the MODELS in your Module

-Add new user to this Group as the Administrator

-Login and test as the desired User

0
eoin ahern
On 2/23/14, 7:31 AM

can literally see nothing on the top menu. on first login. setup as admin. there is no topmenu settings. I need it to view my created module.

this is located in the black taskbar at the very top of the browser window.

0
PT SIVI
On 12/14/13, 8:58 PM

By admin login, please check them on

  1. Settings->User>Group->Administration/Settings. Then check the users and inherited tab
  2. Settings->Technical->User Interface->Menu Items->Settings. And check the one2many field group name
  3. Settings->User->Users->Specific Users. Check the access rights Tab->Application->Administration. Put them blank

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 12/13/13, 7:46 AM
Seen: 5623 times
Last updated: 3/3/16, 12:35 AM