Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

ImportError: No module named web_kanban in version 8 (odoo ) why? .. need a help?

By
Odoo
on 8/8/14, 8:43 AM 4,167 views

2014-08-08 12:41:50,398 14102 INFO ? openerp: database hostname: localhost
2014-08-08 12:41:50,398 14102 INFO ? openerp: database port: 5432
2014-08-08 12:41:50,398 14102 INFO ? openerp: database user: openerp
2014-08-08 12:41:50,398 14102 WARNING ? openerp.modules.module: module web: module not found
2014-08-08 12:41:50,398 14102 CRITICAL ? openerp.modules.module: Couldn't load module web
2014-08-08 12:41:50,398 14102 CRITICAL ? openerp.modules.module: No module named web
2014-08-08 12:41:50,398 14102 ERROR ? openerp.service.server: Failed to load server-wide module `web`.
The `web` module is provided by the addons found in the `openerp-web` project.
Maybe you forgot to add those addons in your addons_path configuration.
Traceback (most recent call last):
  File "/opt/openerp/v8/openobject-server/openerp/service/server.py", line 835, in load_server_wide_modules
    openerp.modules.module.load_openerp_module(m)
  File "/opt/openerp/v8/openobject-server/openerp/modules/module.py", line 266, in load_openerp_module
    __import__('openerp.addons.' + module_name)
  File "/opt/openerp/v8/openobject-server/openerp/modules/module.py", line 71, in load_module
    f, path, descr = imp.find_module(module_part, ad_paths)
ImportError: No module named web
2014-08-08 12:41:50,399 14102 WARNING ? openerp.modules.module: module web_kanban: module not found
2014-08-08 12:41:50,399 14102 CRITICAL ? openerp.modules.module: Couldn't load module web_kanban
2014-08-08 12:41:50,399 14102 CRITICAL ? openerp.modules.module: No module named web_kanban
2014-08-08 12:41:50,399 14102 ERROR ? openerp.service.server: Failed to load server-wide module `web_kanban`.
Traceback (most recent call last):
  File "/opt/openerp/v8/openobject-server/openerp/service/server.py", line 835, in load_server_wide_modules
    openerp.modules.module.load_openerp_module(m)
  File "/opt/openerp/v8/openobject-server/openerp/modules/module.py", line 266, in load_openerp_module
    __import__('openerp.addons.' + module_name)
  File "/opt/openerp/v8/openobject-server/openerp/modules/module.py", line 71, in load_module
    f, path, descr = imp.find_module(module_part, ad_paths)
ImportError: No module named web_kanban
2014-08-08 12:41:50,400 14102 INFO ? openerp.service.server: HTTP service (werkzeug) running on 0.0.0.0:8069

-----------------------------------------------

 

This is my addons path------ from etc folder please replay how to resolve this issue

[options]
; This is the password that allows database operations:
admin_passwd = voso
db_host = False
db_port = False
db_user = openerp3452
db_password = False
addons_path = /opt/openerp/v8/openobject-addons,/opt/openerp/v8/openobject-web/addons
#addons_path = /opt/openerp/v8/openobject-addons,/opt/openerp/v8/openerp-web/addons

;Log settings
logfile = /var/log/openerp/openerp-server.log
log_level = error

----------------------------------------------

This is the command  I am using for restarting server ----------/opt/openerp/v8/openobject-server/openerp-server

 

 

 

0
Brian Martin
On 8/8/14, 4:51 PM

Agree with Libu, if you specified an addons path in your .conf file previously, it will only look at that one location when running odoo8. That is why it is saying it can't find your web modules.  So to fix this, you need to supply all the locations odoo should look as well as your custom stuff. It won't simply append what you have to the existing path.

 

0

Ben Bernard

--Ben Bernard--
1083
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 8/9/14, 1:11 AM

Are you use Odoo Version 8.0rc1? If no, try it. Or try from the latest source.

You can also try not using addons_path in your config file, but give --addons-path direcly as an argument for openerp-server.

yes im using version 8 .o

Odoo
on 8/9/14, 1:18 AM

give --addons-path direcly as an argument for openerp-server. Then how to write the command...?

Odoo
on 8/9/14, 1:19 AM
0

Ludo - Neobis

--Ludo - Neobis--
2387
| 2 2 5
Hoogvliet, Netherlands
--Ludo - Neobis--

Developer

Ludo - Neobis
On 8/8/14, 8:46 AM

Check your addons path. Make sure it includes the web_kanban module.

In version 8, the folder is like so: /opt/odoo/addons and NOT /opt/odoo/openerp/addons. (assuming you have installed Odoo under /opt)

Hi Ludo, This is my addons path and it include web_kanban module addons_path = /opt/openerp/v8/openobject-addons,/opt/openerp/v8/openobject-web/addons

Odoo
on 8/9/14, 12:27 AM

That's really nice, but I cannot look at those directories from here right? Are the modules actually in there?

Ludo - Neobis
on 8/11/14, 3:22 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/8/14, 8:43 AM
Seen: 4167 times
Last updated: 3/16/15, 8:10 AM