Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

ImportError: No module named pycountry

By
Jide Fash
on 7/23/13, 10:26 PM 5,075 views

please help, i get the following errors when installing openerp-magento connector on windows7. what do do please?

OpenERP Server Error

Client Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\http.py", line 204, in dispatch File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\controllers\main.py", line 1132, in call_button File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\controllers\main.py", line 1120, in _call_kw File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\session.py", line 42, in proxy File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\session.py", line 30, in proxy_method File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\session.py", line 103, in send

Server Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\session.py", line 89, in send File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\netsvc.py", line 292, in dispatch_rpc File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\service\web_services.py", line 626, in dispatch File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\osv\osv.py", line 188, in execute_kw File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\osv\osv.py", line 131, in wrapper File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\osv\osv.py", line 197, in execute File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\osv\osv.py", line 185, in execute_cr File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\base\module\wizard\base_module_update.py", line 42, in update_module File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\base\module\module.py", line 617, in update_list File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\web\http.py", line 580, in load_addons File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\modules\module.py", line 133, in load_module File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\magento__init__.py", line 9, in <module> File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\magento\magento_.py", line 17, in <module> File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server.\openerp\modules\module.py", line 133, in load_module File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\magento__init__.py", line 10, in <module> File "C:\Program Files\OpenERP 7.0-20130721-231032\Server\server\openerp\addons\magento\country.py", line 12, in <module> ImportError: No module named pycountry

Tried downloading and installing pycountry directly (in the addons dir) .. no love. Looking into it still --- will keep an eye on the thread.

Levii Smith
on 7/24/13, 1:26 AM

So I did get past that, after downloading pycountry, I build it and added it to the root module location. Now I'm stuck at the meassage: ImportError: cannot import name API

Levii Smith
on 7/24/13, 1:42 AM

not working..i have downloaded and built pycountry and put it in my addons folder but when i update module list it still says no module named pycountry

Jide Fash
on 7/25/13, 6:28 AM
0
Levii Smith
On 7/24/13, 1:53 AM

Got it going, the dependencies need (1) built, and (2) the built version copied to the addons directory: You can get the API part here:

httpsgithub.com/openlabs/magento

The pycountry module is here:

pypi.python.org/pypi/pycountry

Hope it helps.

please where do i put the api? what folder or where? thanks

Jide Fash
on 7/24/13, 7:53 AM

ok so i got everything but when running the api file i get the following error... nameerror: 'name execfile' is not defined. please what do i have to do????

Jide Fash
on 7/24/13, 8:20 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 7/23/13, 10:26 PM
Seen: 5075 times
Last updated: 3/16/15, 8:10 AM