Help

3

Import large file in Odoo

Avatar
jean44

Hello,

When I try to import a large file of 4000 lines in the journal entries, the system is stuck at loading until it displays the message 'please press the F5 key to refresh' and nothing happen after that. I can't figure out where is the problem !

Any help would be appreciated, thank you.

1 Comment
Avatar
Discard
Avatar
Luke Branch
-

@Mos, You may want to check out this post: https://www.odoo.com/forum/help-1/question/csv-product-import-issues-import-preview-failed-due-to-field-larger-than-field-limit-131072-57081 It's more of a hack than a permanent solution, however it may function as a workaround until you find a proper solution. I have not tested this in production so i'd recommend a full filesystem and database backup before trying it.

3 Answers
5
Avatar
Pierre Lamarche
Best Answer

Hello,

You should change the time out limit on the server configuration which is defined by default at 300 seconds.

To import large files, you can shoot it at something like 5000 seconds in order to let the file finish to import.

I know it has already solved some problem of import for us...

Hope it is going to work for you !

Pierre

 

Avatar
Discard
3
Avatar
Abdul Qavi
Best Answer

I had this problem when I was importing 300,000 records. You've two options:

 

1. First option, and better one in your case: Divide the 4000 in smaller chunks and import.

2. Use a Tool like "Navicat for Postgres" or "pgAdmin3" to import data using Postgresql. You don't have to write SQL yourself, rather these tools provide you all the fields and you can carry on without writing any SQL.

 

Hope it helps.

 

Thanks,

Abdul

Avatar
Discard
1
Avatar
jean44
Best Answer

Thank you for your replies, please where I can change the time out limit in Odoo ?

Avatar
Discard