Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

/im_chat/init not available under https/ubuntu 14.04/apache2

By
Francesco
on 1/28/16, 12:35 PM 475 views

Hello,

I have an installation of Odoo 8 on Ubuntu 14.04 and apache2 configured with HTTPS already on a domain ( https://www.mydomain.it/web/ ), but as one of the subfolders. There are other subfolders ( https://www.mydomain.it/somethingelse/ ), that are configured through .conf files in apache2 to deliver contents related to CMS or DMS, etc.

On my installation, I have two (2) databases for my companies.
Under this scenario I am able to:

A. Login as superuser in both the db.

B. Generate and save invoices.

C. Send the invoices to my email account.

Now, I am experiencing the following issues:


1. One I login, I receive the following message:

XmlHttpRequestError Not Found
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /im_chat/init was not found on this server.</p>
<hr>
<address>Apache/2.4.7 (Ubuntu) Server at www.mydomain.it Port 443</address>
</body></html>


2. Once I have generated the invoices, validate and I send them to my email address, I cannot find anymore the header.


3. In case I decide to print them using the functionality Print > Invoice on top of the invoice scree, it appears the "Loading...." image and it goes into a loop.


4. In the "Customers" page (Kanban view), the default company image doesn't show up, but I can see the company image for those where I changed the default with their own one.


I have the suspect that the issue is that an internal path is not visible,

and the appended path goes to timeout

/im_chat/init

Would anybody give me any suggestions on how to proceed to find out where issue is?

Thank you

0

Axel Mendoza

--Axel Mendoza--
10203
| 7 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 1/28/16, 2:07 PM

There is a port configuration for that kind of urls related to the bus longpooling feature in Odoo. By default it's using the port 8072. You just need to proxy those url calls to dispatch to that port in your instance. I'm talking about the longpolling_port config option that it has the default value 8072, you could change it to another one if you like it but your apache config need to dispatch those urls to that port

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 1/28/16, 12:35 PM
Seen: 475 times
Last updated: 1/28/16, 2:07 PM