Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

I have added header in openoffice report, but the openerp is not displaying the header.How to add header in openerp report using openoffice?

By
rosey
on 11/28/14, 3:28 AM 1,102 views

I added a header in openoffice writer (odt file). Then i click Send to server button in openoffice. When i take print from openerp it doesnt shows the header.

But the header is displaying in print preview.

What will be the issue?

&

How can we add header in rml report?

 

 

0

Ivan

--Ivan--
3210
| 5 3 6
Jakarta, Indonesia
--Ivan--
Ivan
On 11/28/14, 4:17 AM

Go to Settings >> Technical >> Actions >> Reports, search for your report, edit it, and check the Add RML Header.  If you have been using the plugin to update the report, open the report using the OpenOffice, make some amendments (type space and then delete it again), then when you push the server, DON'T FORGET TO CHECK THE Corporate Header checkbox.

Then i installed base_rml_edit. Now i can also see the rml file. i tried to edit the file. but it doesnt reflect any thing. what can i do?

rosey
on 11/28/14, 5:06 AM

Rosey, sorry that I've not used base_rml_edit. It would be best if you can contact the author of that module.

Ivan
on 11/28/14, 5:17 AM

Its ok. that is not a problem. Actually my problem is : when i add header in the odt file and send to server. i followed your steps. But still no output.

rosey
on 11/28/14, 5:25 AM

My only problem is to display the header.

rosey
on 11/28/14, 5:26 AM

The odt file on the server folders does not play really important role. What matters is the RML file. If you want to edit through ODT file, then best tool that I know of is using OpenOffice plugins. Using the plugin you can also export the file to RML and put the new RML file in place of the old one.

Ivan
on 11/28/14, 5:35 AM

Actually John, i'm using openoffice to generate the report. But i'm not using any module. I'm just updating the odt file and click send to server button in openoffice-openerp plugin. Is any thing wrong in my flow? Did i want to create a new module for that?

rosey
on 11/28/14, 5:39 AM

Did you check CHECK THE Corporate Header checkbox when sending to server?

Ivan
on 11/28/14, 7:16 AM

Also, you might want to check with the author of base_rml_edit whether their module change how the RML reports definition is stored in the database in any way.

Ivan
on 11/28/14, 7:17 AM

I checked the Corporate Header checkbox when sending to server.

rosey
on 11/28/14, 7:27 AM

base_rml_edit is working for me. But header part is the problem. I cant add header part in any ways.

rosey
on 11/28/14, 7:29 AM

Rosey, you might want to check with the author of base_rml_edit whether their module change how the RML reports definition is stored in the database in any way. Sometimes a module may break the way another module works. Such as the base_report_designer itself breaks the way Odoo gets the the definition file. You cannot update RML anymore from the modules and have to go through OpenOffice to update reports.

Ivan
on 11/28/14, 7:50 AM

I tested in two database, with and without base_rml_edit. But both database doesnt shows header. What will be the problem??

rosey
on 11/28/14, 11:27 PM

I'm out of ideas. You might want to check the RML as Ken Nyen Choo suggested. Another one is to have a database with base_report_designer NOT INSTALLED. I'm not sure that you can only uninstall the module as the remaining settings of this new report will still assume that it is set-up with base_report_designer installed) and update the RML of the report in the module.

Ivan
on 12/1/14, 4:29 AM
0
Ken Nyen Choo
On 11/30/14, 3:40 AM

check your converted RML file whether it contains any information about your new header. You can look for it at your_module/report/xxx.rml

If yes, Go to Settings >> Technical >> Actions >> Reports, search for your report, edit it, and uncheck the "Add RML Header".

otherwise the system will use the default header instead.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 11/28/14, 3:28 AM
Seen: 1102 times
Last updated: 3/16/15, 8:10 AM