Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


I got module installation problem, I can't install any module. Help me please?

Laura Intan
on 7/3/13, 11:52 PM 3,901 views

I got some problem in using openERP, I hope you could help me here..

I uninstalled base kanban module by accidentally, but I've succeeded to install it back.. but my installed project management got uninstalled automatically, and now I can't install it back.. it says : "Constraint Error

You can not have two users with the same login !"

I've been looking for solutions through Google but I don't find any, I really need your help, it's kinda urgent


regards Laura


AJ Schrafel Paper Corp

--AJ Schrafel Paper Corp--
| 4 5 8
Bronx, United States
--AJ Schrafel Paper Corp--

Exploring OpenERP for business

AJ Schrafel Paper Corp
On 7/4/13, 1:23 AM

stop the server.

make sure ALL instances of openERP are stopped by typing ps aux | grep openERP

if there are any open instances kill them

Update the database via the command line

/openerp-server -d <your DB name> -u all

start the server again. see if this fixes your problem

I've tried, seem i got to make a new database.. Thanks for your help anyway :)

Laura Intan
on 7/4/13, 2:34 AM

I too have the same problem after accidentally uninstalling Social Module. Tried updating the database via the command line. Didn't help. Once I uninstalled Social Module, most of the modules except Sales got uinstalled automatically. I think if you hit that point, you should start by installing Address Book, Employee Directory first and then try CRM/Social/Purchase etc. I guess if you re-install any of the main modules without the addressbook, then it keeps throwing the "You cannot have two users with same login" error. \nAnyways, I'm also going to take the new DB route.

Shiva Napoleon
on 8/30/13, 7:45 AM

I think removing Social Module killed everything in one shot. I tried creating a new DB, only to have newer issues (openerp XMLSyntaxError: Opening and ending tag mismatch). Don't know what to do, as a last resolve, I might go and re-install OpenERP again.

Shiva Napoleon
on 8/30/13, 8:47 AM

And what if this problem happen on the production environment?

Rafael Reuber
on 2/6/14, 7:46 PM
On 7/4/13, 12:13 AM

The best way you should drop database, create new and install all again.

I've made some customisation, is there any way to copy the custom table to a new database?

Is there other way to fix it?


Laura Intan
on 7/4/13, 12:24 AM

This answer assumes the database can be dropped without loosing useful data, if the db has important data, dropping is not an option, this answer is useless in that case.

on 7/5/13, 8:37 AM

Seem i got to drop my current db. I can't find another solutions for my problem. thanks for your help

Laura Intan
on 7/7/13, 11:58 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 7/3/13, 11:52 PM
Seen: 3901 times
Last updated: 3/16/15, 8:10 AM