Odoo Help

0

I get some dependency error when install Odoo 9.0

By
vx2008
on 8/7/16, 7:29 AM 460 views

I install Odoo 9.0 according to <Odoo_Development_Cookbook>;

and when I type this lline code: "sudo apt-get install gcc python2.7-dev libxml2-dev libxslt1-dev libevent-dev libsasl2-dev libldap2-dev libpq-dev libpng12-dev libjpeg-dev"
I get error as below:

The following packages have unmet dependencies:
 libxml2-dev : Depends: libxml2 (= 2.9.1+dfsg1-5+deb8u1) but 2.9.1+dfsg1-5+deb8u2 is to be installed
 libxslt1-dev : Depends: libxslt1.1 (= 1.1.28-2+b2) but 1.1.28-2+deb8u1 is to be installed
 python2.7-dev : Depends: libpython2.7-dev (= 2.7.9-2) but it is not going to be installed
                 Depends: libexpat1-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
How shall I resolve these?
Thank you!

1

Ermin Trevisan

--Ermin Trevisan--
4442
| 6 4 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 8/8/16, 2:31 AM

The directives of the Odoo Development Cookbook are based on Debian Jessie. If you use another distribution or release, you might face such dependency issues. Did you try to follow Odoo's instructions: https://www.odoo.com/documentation/9.0/setup/install.html#setup-install-source ?   

Thank you

I will have a try.

vx2008
on 8/8/16, 4:42 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/7/16, 7:29 AM
Seen: 460 times
Last updated: 8/8/16, 4:42 AM