Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

I create a module but it've never seen on the module on the list

By
Séraphine
on 10/10/14, 4:45 AM 1,905 views

Hello,

I've create a module with on new server for odoo v8 : "odoo.py scaffold openacademy myAddons". I put the technical setting for the user, update the list, restart the server, and indicate to it "openacademy".

All I did that's not work .

What I miss please

 

Tks,

Séraph

0

Sudhir Arya (SA)

--Sudhir Arya (SA)--
10150
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow

LinkedIn

Blog

Stackoverflow

Sudhir Arya (SA)
On 10/11/14, 4:54 AM

Make sure your module appears in addons path.

Either you can create your own addons (your own dir) and put you module under it and add your custom addons path or simple way is that put your module under odoo/addons.

After that restart the server, update module list and search for your module.

0
Séraphine
On 10/14/14, 11:51 AM

I see a solution : I add directly in the config file my addons. And it's ok now

:):):)

0
Rachit
On 10/14/14, 1:04 PM

Steps :

1. Place your module in addons folder under hierarchy server/openerp/addons.

2. Restart the server.

3. Give the technical features rights to the user you logged in from the web interface itself.

4. Then there will be options in setting tab(Update Module List).Click on it. Then Your  module will be seen under Installed Apps(Remove filter from the top)

-1
Anand Patel
On 10/13/14, 3:19 AM

Hi,

I think this is permission issue. So just follow the following instructions:

From the terminal go to that directory and to that module like cd /home/openerp/addons/modules

then run this command:

sudo chmod -R 777 *

and then restart the server and and the update module list but if you still not found your module then run this command on the directory where you module is in like if addons/your_module_name then go to the addons from the command and then run the same commad sudo chmod -R 777 *

And then restart the server and update module list this will surely solve your problem

 


 

Tk u Anand, I tested but it's not the real problem because nothing happened at all. :)

Séraphine
on 10/14/14, 10:20 AM
-1

Ben Bernard

--Ben Bernard--
1083
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 10/10/14, 1:42 PM

You have to update the module list. The easiest way is to go to settings and click Update Module List.

I did it many time and on the server too. But nothing happen :)

Séraphine
on 10/10/14, 1:56 PM
-1
Hengky Zhang
On 10/10/14, 6:23 AM

dont forget your module should contain __openerp__.py and __init__.py

Thank u, Yes I create the 2 and more by scaffold but still not see it Another idea,please

Séraphine
on 10/10/14, 12:50 PM

there are many reason that your module is not in the list 1.check you folder permission if you using linux OS 2.you did not create the correct format for the __openerp__.py file 3 etc can you show me you __openerp__.py file and show the log when you do the update module list maybe we can find some clue.

Hengky Zhang
on 10/10/14, 1:00 PM
That's my __openerp__.py in attached.
The problem is my log contain nothing but I put it in the config.
I don't know the solution for the log too.

Tks a lot,


2014-10-10 19:00 GMT+02:00 Hengky Zhang <hengky@sipocs.com>:

there are many reason that your module is not in the list 1.check you folder permission if you using linux OS 2.you did not create the correct format for the __openerp__.py file 3 etc can you show me you __openerp__.py file and show the log when you do the update module list maybe we can find some clue.

--
Hengky Zhang
Sent by OpenERP S.A. using Odoo about Forum Post False

Séraphine
on 10/10/14, 1:44 PM

look like no problem but please try few step below, 1.add parameter installable: True in your __openerp__.py 2.when you find your module in module list make sure you remove the default filter 3. http://acespritechblog.wordpress.com/2012/12/05/how-to-install-new-module-in-openerp-7-0/ 4.if you using ubuntu dont forget the folder and file permission, so the openerp user or whatever user you use can access the module folder

Hengky Zhang
on 10/10/14, 7:40 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/10/14, 4:45 AM
Seen: 1905 times
Last updated: 3/16/15, 8:10 AM