Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


I can't find a specific term in Translated Terms so I can't translate it

on 11/14/14, 4:17 AM 1,162 views


If i go to Sales -> Customers, I see a button ''Create''. 
I want to translate it so I go to Settings->  Translations -> Application Terms -> Translated Terms.
Then I click on Advanced Search and select Old Source is equal to Create.  I see 12 results. 
I translated all 12 of them to my language, logged off and logged in again and I still see 
''Create'' when i go to Sales-> Customers instead of translation in my language.

So I guess that not all the terms are in Translations... Please help me to translate this button Create.

Btw, are there any other words/terms that are not in Translations and if so, how can I access to them?

Thanks in advance.

Juan José Scarafía
On 11/14/14, 8:36 AM

Hi Danijel,

In another question, the user Yenthe, explain very well how to make the translations: click here


Juan José - Ing ADHOC

I actually had a look at this and you can't find the model and field name of a button, since it is not in a model. There is no translation that matches (and links) to the button either so I'm now trying out some things to find this. I'm curious about this too.

on 11/14/14, 10:41 AM

Have you synchronise the terms?

Juan José Scarafía
on 11/17/14, 9:02 AM

Yes I did but I found the solution about how to translate it. See my answer below yours. This adds the new text for the button as he wants.

on 11/17/14, 10:58 AM


| 7 7 8
Turnhout, Belgium

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

On 11/14/14, 10:58 AM

After some trying I found the solution. It turns out that the button is of the type code and the translated field is actually coming from the js.
So what you need to do is this:

1. Go to settings > Application terms > Translated terms
2. Search on translated field for addons/web_view_editor/static/src/js/view_editor.js and with advanced search for old source is equal to Create.

3. If there is not yet a record for the language you wish you can make a new one. If there is one you can customize it. I did this for the Dutch and Flemish language and looks like this:

4. Synchronize your terms for the languages you edit.
5. Refresh the page and behold the new result. For my example in Dutch:


NOTE: This method only doesn't work if you set the language on English for some reason.. I'm testing this further and will post back if I also find the solution for this. This might be a bug too.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 11/14/14, 4:17 AM
Seen: 1162 times
Last updated: 3/16/15, 8:10 AM