Odoo Help

2

2
9 Answers
2
Alexander Ivanov
7/10/15, 11:45 AM

Hi!

If your users catch

You do not have access to this database or your invitation has expired. Please ask for an invitation and be sure to follow the link in your invitation email.

Then, it seems, they are already in the database. You need to "Re-send Invitation Email".

  1. Go to Settings -> Users -> User -> Re-send Invitation Email (the top right corner of the user's card). Don't needs for new users.

  2. When user goes to a password reset he don't need to reset a password. Let him to press "Log in with Google"

It works for me fine.

1
Anukoon Peangsuntia
12/16/15, 12:24 PM

Hi,

I also faced with the same issues and can fixed it. please check two point in your system.

1. Configure outgoing email servers.

2. Select option "Allow external users to sign up" and maintain "Template user for new users created through signup".

Hope this help. :)

1
tansadio
4/26/15, 2:24 PM

Hi. Please Someone has resolved this problem?

0
Anu Vimolkiattisak
3/30/17, 6:03 AM

I fixed mine with this workaround:


Create new User Then

User > Oauth > Oauth User ID = email@domain.com


in path: add_on/auth_oauth/models/res_users.py

Replace line:

oauth_uid = validation['user_id']


with:

oauth_uid = validation['email']


This way user can authenticated by email not numbered user_id and you don't have to turn on user signup.

0
lanoe
3/12/15, 4:28 AM

me too

Ask a Question
Writer
Tags
Keep Informed
6 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now