How to use the OpenOffice Report Designer ( base_report_designer ) on the SaaS with XML-RPC Secure | Odoo

How to use the OpenOffice Report Designer ( base_report_designer ) on the SaaS with XML-RPC Secure

Since beginning of June 2013 , I cannot connect anymore my OpenOffice Report Designer to my SaaS instance. Can you help me?

Sébastien Versailles (sve)
Sébastien Versailles (sve)
152
| 5 2 5
Asked on 6/14/13, 5:40 PM
5
vote
9382 Views

I have also experienced this, but the instructions below do not seem to work. Any more ideas? It was working perfectly up to 3rd July 2013 - has something been changed?

CambTEK Limited, Tony Hawkins
on 7/5/13, 3:34 PM
This question has been included in the official documentation.

Hello,

Since beginning of June 2013, we are using the protocol XML-RPC Secure to connect the OpenOffice Report Designer to the OpenERP Online instances.

Here are the steps you need to follow to use the new plugin:

  • 0a) Don't forget to add a password to your user ( cf question 4900 )
  • 0b) Don't forget that this plugin works with OpenOffice and with Libreoffice until V3.6 , but not with Libreoffice V4.0+
  • 1) In your instance , go to Settings/Modules/base_report_designer, click on "upgrade"
  • 2) In your instance, go to Settings/Configuration Wizards/OpenERP Report Designer Installation/Set as To Do/Launch/Download the file.
  • 3) Rename your file by adding ".zip" at the end of the file name
  • 4) In OpenOffice, (Tools/Extension manager) disable the existing extension
  • 4b) If necessary, delete manually the plugins from the application data (google..)
  • 5) Restart OpenOffice
  • 6) In OpenOffice, (Tools/Extension manager) Add the new extension file
  • 7) Restart Openoffice
  • 8) In Openoffice Report Designer/Server parameters ; fill in with the following settings: Server: YOUR_INSTANCE.my.openerp.com Port: 443 Protocol: XML-RPC secure
  • 9) Continue with the same steps as before ( type in the name of your instance )

I hope it will help you.

Sébastien Versailles (sve)
Sébastien Versailles (sve)
152
| 5 2 5
Answered On 6/14/13, 6:15 PM
3
vote

the openoffice extension as downloaded thru the link (step 2 above) provided during the setup of the base_report_designer module creates an error when installing it as an OO extension. Any fix to this?

AD LIBITOM, Ad Libitom
on 9/30/13, 10:01 PM

hello sir, even i did the same thing but i'm not able enable the extension base_report_designer file in openoffice can u plz help it out

Sampath Kumar S
on 10/30/13, 8:40 AM

when i follow step 7 and restrat office it not show me openoffice report designer where i find this?

bakhtawar
on 12/6/13, 8:27 PM

Maybe an answer will appear... https://answers.launchpad.net/openobject-addons/+question/241854

Moore Works, Dale E. Moore
on 1/7/14, 11:25 PM

I had the same issue and was attempting to test out any combination of the recommendations above to attempt to solve and finally found one that worked for me.

On SaaS version of Odoo Online (v8); follow the steps above to download the configuration wizard and .zip file locally from your Odoo instance. This was done using the most recent version of OpenOffice 4 - all the advice seemed to point people to different ports or RPC protocols, but using standard RPC and port 80 worked for me using Windows 8 and OpenOffice 4.

  1.  In your instance , go to Settings/Modules/base_report_designer, click on "upgrade"
  2.  In your instance, go to Settings/Configuration Wizards/OpenERP Report Designer Installation/Set as To Do/Launch/Download the file.
  3.  Rename your file by adding ".zip" at the end of the file name
  4.  In OpenOffice, (Tools/Extension manager) disable the existing extension
  5.  If necessary, delete manually the plugins from the application data (google..)
  6.  Restart OpenOffice
  7.  In OpenOffice, (Tools/Extension manager) Add the new extension file
  8. Restart Openoffice
  9.  In Openoffice Report Designer/Server parameters ; fill in with the following settings: Server: YOUR_INSTANCE.odoo.com Port: 80 Protocol: XML-RPC (I did NOT select 'secure)
  10.  Select Next
  11. DB name: "your instance name"; username: your profile username, not Odoo OAuth name (in my case: "admin"); Password: your system password
  12. Click 'Connect' - you should see a message that responds with: "You can start creating your report in the current document; After creating, sending to the server"

Hope this help!

Arthur Lapies
Arthur Lapies
7
| 1 0 1
Answered On 1/26/15, 9:06 AM
0
vote

I followed your instructions, but keep getting wrong username / password if I try to connect with the Report Designer. For 100% sure the username & password are o.k., I use admin / <password> with which I can logon to OpenERP without any problem.

In the default openerp-server.conf is the next line:

specify the TCP port for the XML-RPC Secure protocol

xmlrpcs_port = 8071

Sure the port 443 mentioned in your answer should be used, not 8071?

wjn
wjn
155
| 5 1 6
Answered On 9/29/13, 12:21 AM
0
vote

not for SaaS but for an installation in a local network you have to use the port of the apache server and NOT any other port like 8069, 8070, 8071 related to RPC, in my case 80 work fine (even from a PC which is not the server), however I do not know what works for SaaS

M. Höppner
M. Höppner
142
| 4 1 5
Answered On 9/29/13, 12:32 AM
0
vote

Dear Friend,

i install Ubuntu 14.04 and install LibraOffice V4 . when i clink on OpenErp Report designer menu . its no working .no error showing also.

kindlly advice me.

thanks,

suresh rao

 

SureshRao
SureshRao
4
| 1 0 1
Answered On 9/17/14, 7:46 AM
0
vote

Suresh, the plugin only works for OpenOffice/LibreOffice 3.2.

Ivan
on 11/28/14, 10:17 AM

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice.

Ask a Question

About This Forum

This community is for professionals and enthusiasts of our products and services.


Read Guidelines

Question tools

5 follower(s)

Stats

Asked: 6/14/13, 5:40 PM
Seen: 9382 times
Last updated: 1/26/15, 10:24 AM