Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


How to use a module of previous versions Odoo 8?

Diogenes Ojeda
on 1/15/15, 6:45 PM 1,061 views

Hello, I wanted to ask you a question:

Is there any way to upgrade a module running on version 7.0 of Odoo but no longer appears in the repositories of this?

For example earlier in version 7.0 I used the Product  Historical Margin module, downloading of online applications, this module now no longer appears in shock. I searched the internet and copied to the addons folder, but I still do not appear to mount.

How I can fix this? Or should rewrite module?

Thank You


Stephen Mack

--Stephen Mack--
| 8 8 9
Santiago, Chile
--Stephen Mack--

Some people call me a karma whore, I only ask for 10 points if you like my answer and 15 if I happen to get it correct.

Stephen Mack
On 1/15/15, 7:10 PM

I assume you are refering to this module developed by camptocamp.  As you said it is available for OpenERP 6.1 and 7.0 and the source code is located on LaunchPad, but it also apears to have be adopted by the OCA with a recient 8.0 branch.

I hope this is the same module.

UPDATE: After further review it seems that it has a note saying that it is currently unported (not upgraded for Odoo v8).  You may want to post a comment on the OCA email list to get a response directly from camptocamp.

Hi, thanks for your answer. Means that the module there will probably work published in version 8.0 of Odoo? I still have not tried, but presumably just take it to the Addons folder I can run? Thank You

Diogenes Ojeda
on 1/15/15, 7:24 PM

Try it on a test database but join the oca email list if you want to talk to the developer.

Stephen Mack
on 1/15/15, 7:25 PM

I'll do it and I mention how I was Thanks for the info

Diogenes Ojeda
on 1/15/15, 7:29 PM

De nada vecino.... suerte!

Stephen Mack
on 1/15/15, 7:32 PM

Jjajaja Gracias!

Diogenes Ojeda
on 1/15/15, 7:36 PM

Hello, I downloaded the module, and I have taken to the Addons folder, then restart the server, the module appears ready to install me in the list of local modules, but to give Install, tells me that depends on another module: product_get_cost_field The ugliest, is that module did not appear in the list of local modules from Odoo, however much they put into the Addons folder. So to resolve the error, what has happened to me is, edit the file openerp.py these lines. {'name': 'Product Historical Margin' 'version', '0.2', 'author', 'Camptocamp' 'maintainer' 'Camptocamp' 'category', 'Accounting & Finance' 'complexity': "normal", # easy, normal, expert 'depends': ['product_get_cost_field' 'product_standard_margin' 'account', 'sale', ] And remove 'product_get_cost_field dependencies. I have not tried it, but maybe that will solve the problem, I have looked in the file and product_historical_margin.py not seem to be there any reference or call the logic of that module (product_get_cost_field), so I have faith that worked ... Anyway because I'm not an expert programmer, it is lawful to do this? That is my question. Thank You

Diogenes Ojeda
on 1/18/15, 4:26 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 1/15/15, 6:45 PM
Seen: 1061 times
Last updated: 3/16/15, 8:10 AM