Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to solve this error when trying to install stock_picking_reopen on Odoo?

By
Pascal Tremblay
on 1/24/15, 2:17 PM 2,227 views

Hello gang,

I'm trying to install stock_picking_reopen on my odoo 8.

acount_invoice_reopen is already installed.

I get this error :

Odoo Server Error

Traceback (most recent call last): File "/home/odoo/openerp/http.py", line 525, in _handle_exception return super(JsonRequest, self)._handle_exception(exception) File "/home/odoo/openerp/http.py", line 562, in dispatch result = self._call_function(**self.params) File "/home/odoo/openerp/http.py", line 302, in _call_function return checked_call(self.db, *args, **kwargs) File "/home/odoo/openerp/service/model.py", line 113, in wrapper return f(dbname, *args, **kwargs) File "/home/odoo/openerp/http.py", line 299, in checked_call return self.endpoint(*a, **kw) File "/home/odoo/openerp/http.py", line 791, in __call__ return self.method(*args, **kw) File "/home/odoo/openerp/http.py", line 395, in response_wrap response = f(*args, **kw) File "/home/odoo/addons/web/controllers/main.py", line 953, in call_button action = self._call_kw(model, method, args, {}) File "/home/odoo/addons/web/controllers/main.py", line 941, in _call_kw return getattr(request.registry.get(model), method)(request.cr, request.uid, *args, **kwargs) File "/home/odoo/openerp/api.py", line 241, in wrapper return old_api(self, *args, **kwargs) File "/home/odoo/openerp/addons/base/module/module.py", line 450, in button_immediate_install return self._button_immediate_function(cr, uid, ids, self.button_install, context=context) File "/home/odoo/openerp/api.py", line 241, in wrapper return old_api(self, *args, **kwargs) File "/home/odoo/openerp/addons/base/module/module.py", line 498, in _button_immediate_function registry = openerp.modules.registry.RegistryManager.new(cr.dbname, update_module=True) File "/home/odoo/openerp/modules/registry.py", line 346, in new openerp.modules.load_modules(registry._db, force_demo, status, update_module) File "/home/odoo/openerp/modules/loading.py", line 363, in load_modules loaded_modules, update_module) File "/home/odoo/openerp/modules/loading.py", line 263, in load_marked_modules loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules, perform_checks=perform_checks) File "/home/odoo/openerp/modules/loading.py", line 158, in load_module_graph models = registry.load(cr, package) File "/home/odoo/openerp/modules/registry.py", line 148, in load model = cls._build_model(self, cr) File "/home/odoo/openerp/models.py", line 595, in _build_model original_module = pool[name]._original_module if name in parents else cls._module File "/home/odoo/openerp/modules/registry.py", line 101, in __getitem__ return self.models[model_name] KeyError: 'stock.journal'

Sombedody could help? 

 

Odoo doesn't restart now. Same error. Second time today. I will forget this module. It seems to dangerous for me.

Pascal Tremblay
on 1/24/15, 2:27 PM
0

Pascal Tremblay

--Pascal Tremblay--
1312
| 5 2 7
Alma, Canada
--Pascal Tremblay--


Pascal Tremblay
On 1/24/15, 2:35 PM

Ok, I have set the state of the module in ir.module.module table to « uninstalled ». I could restart! Thanks

Same error when I try to install sale_order_reopen. I am sad because those *_reopen modules seem very interesting.

Pascal Tremblay
on 1/24/15, 2:41 PM
0
Gaëtan Frenoy
On 5/11/15, 5:36 AM

stock_picking_reopen (from https://www.odoo.com/apps/modules/8.0/stock_picking_reopen/) is only a copy of the v7 module that has not been properly migrated to v8.

It will never work.

stock_cancel from OCA (https://github.com/OCA/stock-logistics-workflow/tree/8.0/stock_cancel) should be more helpful.  Before proceeding, please read https://github.com/OCA/stock-logistics-workflow/issues/59 and make sure you understand the consequences.

I have downloaded your stock_cancel, changed the permission, update modules list in Odoo, like I have already did 200 times... But I don't see this new module in my list???/$%?"/$&W"% Heu!!!!!! Where is it??

Pascal Tremblay
on 5/11/15, 6:50 AM

For some reason, it is set to "Installable: False"; not sure why, I guess the author estimates it's not reliable enough? If you want to give it a try, you'll need to set "Installable" to True. It worked for me but as usual (!dislaimer!), use it at your own risks!

frenoy.net, Gaëtan Frenoy
on 5/11/15, 7:05 AM

https://github.com/OCA/stock-logistics-workflow/issues/109

Pascal Tremblay
on 5/11/15, 8:07 AM

Thanks, answer edited to reflect why it has been disabled.

frenoy.net, Gaëtan Frenoy
on 5/11/15, 8:24 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 1/24/15, 2:17 PM
Seen: 2227 times
Last updated: 5/11/15, 8:26 AM