Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

3

How to solve the font issue "Can't map determine family/bold/italic for dejavu"?

By
Vincent LE PAPE
on 2/14/13, 6:39 AM 3,717 views

After installation of Windows All-In-One package there is an error when trying to preview Header/Footer data in the company details or when trying to preview a sales document.

I have tried on 2 different computers and still have the issue. Is the Windows All-In-One package fully functional for v7 ?

Content of the error message :

Can't map determine family/bold/italic for dejavu sans handle_pageBegin args=() (<type 'exceptions.valueerror'="">, ValueError("Can't map determine family/bold/italic for dejavu sans\n handle_pageBegin args=()",), <traceback object="" at="" 0x04be9d00="">)

3

tolstoj

--tolstoj--
899
| 6 5 8
Germany
--tolstoj--

hi

tolstoj
On 2/14/13, 6:52 AM

The problem is probably due to a missing DejaVu font. DejaVu is an opensource font. You can download it for free here: http://dejavu-fonts.org/wiki/Download

To install the font you can either:

  • Copy the ttf files to c:\windows\fonts or the equivalent folder on your Windows system
  • Open the control panel. Open the fonts app. Drag and drop the ttf files in there.

Once you have installed the font, you must either restart the OpenERP server or restart Windows. It's simpler to restart Windows. You can restart OpenERP by going to the Services panel in Windows.

Installing the font did solve the problem. Thanks for your help

=> I would suggest to include the font in the installation package

Vincent LE PAPE
on 2/14/13, 7:28 AM

You have to extract them on the path windows->fonts then restart your server or your computer, be sure that your extract the full package of dejavu fonts

Yug Faa
on 2/14/13, 9:28 AM

Thanks alot Yug Faa..

Manish
on 2/26/13, 10:10 AM

Yes I did it and worked just fine.

Andres Ruiz
on 3/3/13, 12:14 PM

You can also go to the control panel > fonts and then drag and drop the font in there. All you have to do then is either restart the OpenERP server via the services panel. This saves having to restart the computer. Either way is fine I just wanted to give an alternative.

Stephenn Burns
on 3/7/13, 9:00 PM

I had the same problem and now it's resolve

Plessis
on 5/14/13, 3:04 PM
0
Joep Mulder
On 7/26/13, 11:39 AM

This is for Windows where do I need to copy the files for linux?

for Debian/Ubuntu its /usr/share/fonts/

tolstoj
on 7/26/13, 12:42 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 2/14/13, 6:39 AM
Seen: 3717 times
Last updated: 3/16/15, 8:10 AM