Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

How to setup an instance accessible via No-ip address?

v7
By
Fred
on 2/12/13, 4:21 AM 8,157 views

I would like to set up an instance whereby the client can access OpenERP using a no-ip address. How can I set this up?

4

Ahmet Altinisik

--Ahmet Altinisik--
2137
| 8 7 10
ANKARA, Turkey
--Ahmet Altinisik--

http://www.altinkaya.eu

Ahmet Altinisik
On 2/14/13, 4:30 AM

Required settings are not openerp related. You should first find your servers local ip address with command.

ifconfig

Local IP address of your server will be something like 192.168.1.* or 10...* note that address down and enter to the administration page of your zyxel model/router. (this will be the gateway address in the ifconfig output.

Go to the NAT settings and make a new entry with the local IP of your openerp server and port 8069. For the external port you should also define a port 8069 for example.

Now you can access with your new http://yourname.no-ip.org:8069 address

If you need help about setting up NAT settings in your modem take a look at this video http://www.youtube.com/watch?v=9OVYC37BQZg

All done. Thanks for the effort. I downloaded and installed the NO-IP updater, set the OpenERP domain alias to my NO-IP IP and set my router with my machines IP to port 8069

Fred
on 2/15/13, 5:29 AM

if my answer is ok you should accept it by clicking check button and make it green

Altınkaya Elektronik Cihaz Kutuları imalat Ticaret ltd sti, Ahmet Altinisik
on 2/25/13, 3:58 AM

Answer accepted

Camptocamp SA
on 3/8/13, 12:11 PM

"if my answer is ok you should accept it by clicking check button and make it green" Can't find any check button :(

Fred
on 3/13/13, 3:49 AM

It is the ✓ just below the answer vote counter. As I clicked on it, it is now green.

Camptocamp SA
on 3/13/13, 6:06 AM

Thanks, NOw I know :)

Fred
on 3/13/13, 6:09 AM
0
Fred
On 2/14/13, 3:48 AM

Hello Allen, I have used this before but it has been a while so please bear with me.

First a bit about my setup. OS: Linux Kubuntu 12.10 OpenERP: Version 7 .deb latest Interent: wired DSL connection with a zyxel modem/router.

I can access my OpenERP localy with:127.0.0.1:8069

I set up a host with NO_IP :afbbodenbelag.no-ip.org, respectively :87.237.174.79. I went to configuration->general settings and added: 87.237.174.79 to Alias Domain Using either NO-IP host times out or throws me a login screen. Open ERP login does not work. Neither does the login to my linux machine.

I remember something about setting/editing some stuff in one or various /etc file(s) maybe also something somewhere else, but not sure anymore what and where. It has been a long time since I tried getting OpenERP to run.

Any ideas?

0
Alan Bell
On 2/12/13, 5:34 AM

OpenERP doesn't really care what domain name it is on, a dynamic DNS entry will work just like a real DNS entry. You just need to open the appropriate port (8069 by default) and it should work fine. Are you experiencing a problem with it?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/12/13, 4:21 AM
Seen: 8157 times
Last updated: 3/16/15, 8:10 AM