Odoo Help

0

How to set a default value in debug mode?

By
Pascal Tremblay
on 12/31/16, 6:39 PM 621 views

Hello there,

We are on Odoo 8.

I set a value for a value for the "Fiscal Year" field. 

After, I go in the debug menu to save my new Fiscal year value. I save it for the user (or all the users).

When I come back, the field is still empty... 

I'm pretty sure that it worked before...

If I try to save a new default value for the field "Target Moves", it works. 

What is the problem?



EDIT #1

I have many others cases like this one where the default value doesn't work. 


EDIT #2

I also notice that the field "Condition" doesn't appear now when I select "Set defaults" in the developper menu...

What is the problem... I don't understand.

2
NareshKumar.P
On 1/4/17, 3:38 AM

The set Default option in working fine . You Can try by fill all entries in the form and goto set default select which field you want set default while creating next time and select all users and click save default button.

 Next time while creating form the values will be shown default in the form.

But while upgrading the module the set default option will be revert back. For that you need to write in python Code itself

Ex:

_defaults = {  'free_member': False,

'state': 'draft',

}

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 12/31/16, 6:39 PM
Seen: 621 times
Last updated: 1/4/17, 9:05 AM