Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to Restore Database from ancient server

By
sunwukong69
on 5/7/13, 10:51 PM 3,081 views

I try to figure out how to restore a database from a local installation to a newly configured openerp on another local server.

The origin db is a server on my laptop and the destination is a server on a Raspberry Pi with 512m of memory. Openerp is installed on the Raspberry Pi but anything I try result on 'Impossible to restore database'.

For the restoring process I do the following (v7, Postgresql 9.1.9):

1-I save the database in the administration of the old openerp server--> which give me a ".dump" file.

2-I move the .dump file on the new server and, through the same database administration menu, I restore it with the same name of the blank database.

Help is welcome.

An interesting project. Not sure I'd be impressed with the speed though! Do you have further details about how you are doing the dump from the original database and how you are attempting to do the restore. Looking through the openerp and postgres logs would be a good place to start to further expand on what the actual error is.

Ian Beardslee
on 5/8/13, 12:17 AM

The speed with the Pi is actually a lot faster than I thought, response is around 2-3 seconds when charging new menus and almost inmediate when in the same menu. There is still no datas though...

sunwukong69
on 5/8/13, 1:34 AM
0

Davide Corio

--Davide Corio--
1822
| 4 3 7
Bricherasio, Italy
--Davide Corio--

Odoo Evangelist and Consultant

Davide Corio
On 5/8/13, 5:30 AM

You are probably missing the pgpass file on the target server.

Inside the home of the system user that run the openerp process, create an hidden file called .pgpass.

Inside this file you have to write something like:

localhost:5432:*:myuser:mypassword

replace myuser and mypassword with the correct postgresql credentials (the ones you can see inside the openerp's server config file).

Set the correct file permission: chmod 600 .pgpass

Restart OpenERP then try to restore the dump file.

If this doesn't work, try to run OpenERP in foreground (by typing openerp-server --all-the-switch-you-need in the shell). You should notice that OpenERP is asking for the password in the server's shell. If this happens, you need to check pg credentials or auth mechanism in the pg_hba.conf file.

Thanks for the answer. To be sure...: localhost:5432[local IP adress:port]:*[?]:myuser:mypassword? We are speaking of the "openerp/server/openerp-server.conf"? "--all-the-switch-you-need in the shell", what are the switches, ports? I tried option 1 with no results.

sunwukong69
on 5/8/13, 9:50 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/7/13, 10:51 PM
Seen: 3081 times
Last updated: 3/16/15, 8:10 AM