Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


How to remove decimals in invoice ? [Closed]

Anne-Sylvie Burri
on 5/6/13, 11:28 AM 3,151 views

The Question has been closed

Ray Carnes
on 05/08/2013 13:55:21

Hi everybody !

I try to remove decimals for "Quantity" and "Discount" in invoice.

I already change in settings/Database Structure/Decimal Accuracy but nothing changes in my invoice.

Someone could help me ?

Many thanks in advance.



Ray Carnes

--Ray Carnes--
| 9 7 9
Greater Los Angeles, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0 and Odoo 8.0, 9.0 (Since 2012)

Completed Functional and Technical Training.

Major Skills:

  • Needs Discovery and Requirements Analysis;

  • Function and Technical Specifications;

  • Project Planning;

  • Prototyping and Proof of concepts;

  • Data migration;

  • Configuration & Customization (UI and modules);

  • Integration - data, business logic and service levels;

  • Training and Knowledge transfer;

  • Go Live support;

  • Help desk;

  • Version Migration.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

Ray Carnes
On 5/6/13, 2:12 PM

Reports should be using the get_digits function to determine how many decimals to display.

In version 7.0, Invoices call this function to return the decimal accuracy of the Account.

Check the digits of the Account record under Settings -> Technical -> Database Structure -> Decimal Accuracy

Thanks for your answer. If I can't modify the decimal accuracy "Account" beacuse of links with other modules. Do you know in wich file is it possible to modify this function ?

J.-M. Burri - Bureau ing.-conseils informatique, Anne-Sylvie Burri
on 5/7/13, 7:04 AM

account_print_invoice.rml in addons/account/report - just replace the function with the number of digits you want to use. Once you get this working, I suggest you create your own RML file and own report, so it will not be reverted if you upgrade OpenERP.

Bista Solutions US, Ray Carnes
on 5/7/13, 2:20 PM

Thank you very much it works perfectly :-) I gonna follow your advice and create my own report.

J.-M. Burri - Bureau ing.-conseils informatique, Anne-Sylvie Burri
on 5/8/13, 5:21 AM

Sudhir Arya (SA)

--Sudhir Arya (SA)--
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow




Sudhir Arya (SA)
On 5/6/13, 11:35 AM

Make sure you have made changes in Product Unit of Measure for Quantity and Discount for Discount in Decimal Accuracy and set Digits=0.

Thanks for your answer. I already changed this parameters but no results in my invoice.

J.-M. Burri - Bureau ing.-conseils informatique, Anne-Sylvie Burri
on 5/6/13, 11:38 AM

Same thing is working for me.

Sudhir Arya (SA)
on 5/6/13, 11:40 AM

It changes in the lines form in OpenERP but not in the report.

J.-M. Burri - Bureau ing.-conseils informatique, Anne-Sylvie Burri
on 5/6/13, 12:16 PM

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 5/6/13, 11:28 AM
Seen: 3151 times
Last updated: 3/16/15, 8:10 AM