Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

6

How to log in using google account in odoo 8

By
Vimesh Chaudhari
on 2/6/15, 10:02 AM 3,498 views

Important: Make sure Odoo is correctly configured to send email before starting this tutorial. Odoo will need to email an activation link when you enable OAUTH.
So, let’s get started.


Enabling OAuth Support in Odoo
1. Login to Odoo as the Administrator 
2. Browse to Settings -> Configuration -> General Settings:
3.  □ Allow external users to sign up ->check this
4. Template user for new users created through signup must be Template User.


Enabling Google App Engine Admin Console
1. Browse to https://admin.google.com and login as the Google domain adminstrator 
2. Click More Controls at the bottom of the page 
3. Click More Google Apps 
4. Click the X next to Filter: Top featured services to clear the filter 
5. Scroll down the list and click Google App Engine Admin Console 
6. Turn it ON for everyone 


Create Google Apps OAuth2 access for Odoo
1. Browse to https://console.developers.google.com/project and if necessary login 
2. Click Create Project 
3. In Project Name enter whatever you want, e.g. odoo
4. Click Create 
5. In the menu on the left, expand APIs & auth then click Credentials 
6. Click Create new Client ID 
7. Under Authorized JavaScript origins enter your server domain name, e.g. http://mydomain.com 
8. Under Authorized redirect URI enter you domain plus the OAUTH path, e.g. http://mydomain.com/auth_oauth/signin 
9. Click Create client ID 
10. In the menu click Consent screen 
11. Select an email address from the drop down menu 
12. In Product Name enter a description, e.g. odoo
13. Click Save 
14. In the menu click Credentials and leave the browser window open 


Add Google OAuth2 credentials to Odoo
1. Login to Odoo as the Administrator 
2. Browse to Settings -> OAuth Providers 

Note : If you don't found OAuth Providers, Please go to General Settings and check the checkbox of Use external authentication providers of authentication.

3. Click Odoo.com Accounts to open the settings window 
4. Click Edit then uncheck the Allowed checkbox 
5. Click Save then click Providers to return to the list 
6. Click Google OAuth2 to open the settings window 
7. Click Edit 
8. From the Google Developers Console, copy and paste the Client ID into the box in Odoo 
9. Check the Allowed checkbox 
10. Click Save 

Good Explaination..!

Mohit Kotak (MK)
on 2/7/15, 12:12 AM

when i select database and click to login with google it shows Error Access Denied. don't allow to login with email id and password. also question is login with google allow to directly login with email and password or user need to first sign up and then user can login?

HappyOdoo
on 8/28/15, 6:36 AM
0
JA
On 2/14/15, 1:32 PM

Following this, gives you the option to use googleauth. The problem is that if you select this option, users who dont have a google account, do not have access to register without google. 

It would be nice, if both options could be used. With Google, facebook or just regular template user.

Hello JA, In odoo authentication your need is already satisfied. To use both the options like sign up with template user or google user you have to just got to Setting->General Settings and check checkbox Allow external users to sign up in Portal access.

Vimesh Chaudhari
on 10/6/15, 5:04 AM
0
tazus
On 10/5/15, 7:58 AM

In this program, I have one problem when using https:// as default protocol, the "request.httprequest.url_root" from controllers/main.py sending out http:// return_uri, so, the program keep said it "Error: redirect_uri_mismatch" error. So, what can be done? I try to modified the main.py to use "web.base.url" but keep getting the following error:

File "/opt/odoo/addons/bus/bus.py", line 188, in poll

raise Exception("bus.Bus unavailable")"

And the system was lock at 500 error.

So, anyone can share the possible solution will be appreciated.

Are you running your odoo instance using odoo.py or in openerp-gevent mode or openerp-server mode? If you are using openerp-server mode, Please try running server using odoo.py Please check the odoo dependencies installation.

Vimesh Chaudhari
on 10/6/15, 4:30 AM
0
Min Wai Chan
On 8/5/15, 5:04 AM

I think there are some mistake on this line.

Under Authorized redirect URI enter you domain plus the

OAUTH path, e.g. http://mydomain.com/auth_oauth/signin

Should change to

http://mydomain.com/openerp.wsgi/auth_oauth/signin

At least that is how I got it working on odoo 8

0
JA
On 2/14/15, 1:32 PM

Following this, gives you the option to use googleauth. The problem is that if you select this option, users who dont have a google account, do not have access to register without google. 

It would be nice, if both options could be used. With Google, facebook or just regular template user.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/6/15, 10:02 AM
Seen: 3498 times
Last updated: 10/6/15, 4:58 AM