Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to installed IM module in 7.0?

By
Farid Ghanchi
on 2/8/14, 3:33 AM 3,489 views

In Stable version not install Instant Messaging

Download the IM from apps

and set the addons then Run the server

The web module is provided by the addons found in the openerp-web project. Maybe you forgot to add those addons in your addons_path configuration. Traceback (most recent call last): File "/home/netpro/Latest 7.0/server/7.0/openerp/service/__init__.py", line 60, in load_server_wide_modules openerp.modules.module.load_openerp_module(m) File "/home/netpro/Latest 7.0/server/7.0/openerp/modules/module.py", line 415, in load_openerp_module getattr(sys.modules['openerp.addons.' + module_name], info['post_load'])() File "/home/netpro/Latest 7.0/web/7.0/addons/web/http.py", line 628, in wsgi_postload openerp.wsgi.register_wsgi_handler(Root()) File "/home/netpro/Latest 7.0/web/7.0/addons/web/http.py", line 517, in __init__ self.load_addons() File "/home/netpro/Latest 7.0/web/7.0/addons/web/http.py", line 580, in load_addons m = __import__('openerp.addons.' + module) File "/home/netpro/Latest 7.0/server/7.0/openerp/modules/module.py", line 133, in load_module mod = imp.load_module('openerp.addons.' + module_part, f, path, descr) File "/home/netpro/Latest 7.0/addons/7.0/im/__init__.py", line 2, in <module> import im File "/home/netpro/Latest 7.0/addons/7.0/im/im.py", line 33, in <module> from openerp.http import request ImportError: No module named http

0

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 2/8/14, 2:03 PM

If it is for V7.0 This can help you, but it is very confusing. Do a search in google for : februDOTsoluvasDOTcom how to activate instant messaging on OpenERP 7   http://febru.soluvas.com/2013/09/how-to-activate-instant-messaging-on.html

This one seems to be good for OpenERP V7.0

Do a search in BITBUCKET: *anybox web_im *   https://bitbucket.org/anybox/web_im

Good luck

 

Response added 6 Months later.

I can confirm that https://bitbucket.org/anybox/web_im is working fine under V7.0.

I've also posted a video showing web_im in action (see under https://bitbucket.org/anybox/web_im/issue ).

Try to use it, and if you encounter any problem resubmit your questions.

 

 

edit by Gunnar: added the 2 links. There is a nasty pop-up in the middle of the http://febru.soluvas.com/2013/09/how-to-activate-instant-messaging-on.html page which can not be clicked away though. Maybe if the author reads this post he might be able to take care of that? It's pretty difficult to follow the instruction with this thing on top if it

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/8/14, 3:33 AM
Seen: 3489 times
Last updated: 3/16/15, 8:10 AM