Odoo Help

1
11 Answers
4



I had faced the same issue while installing odoo 12.

It was solved by typing ..

~# pip3 install libsass==0.12.3


Thanks...

Shameem Babu @ iWesabe


2
Hazem Mahmoud
10/5/18, 3:02 PM

Hi Dyvia,

I followed the following steps and the problem has been solved

Download and install SassC and LibSass

cd /usr/local/lib/
sudo git clone https://github.com/sass/sassc.git --branch 3.2.1 --depth 1
sudo git clone https://github.com/sass/libsass.git --branch 3.2.1 --depth 1
Then add the path to /etc/environment
sudo nano /etc/environment
# Add this line to the end of the file
SASS_LIBSASS_PATH="/usr/local/lib/libsass"
# Flush the changes… source /etc/environment # Make sure it worked… echo $SASS_LIBSASS_PATH # Now you can make SassC… cd /usr/local/lib/sassc/ sudo make

Then update SassC

cd /usr/local/lib/sassc/
SASS_LIBSASS_PATH="/usr/local/lib/libsass"; sudo make

The final step is to make sure the sassc command is in your PATH by creating a symbolic link in /usr/local/bin/.

cd /usr/local/bin/
ln -s ../lib/sassc/bin/sassc sassc

Restart your odoo and open it in new incognito window

The steps in the following link with some changes I have made

http://crocodillon.com/blog/how-to-install-sassc-and-libsass-on-ubuntu

Regards,

Hazem

0
Avatar

Navrang Oza

--Navrang Oza--
Navrang Oza
843
| 3 2 6
Gandhinagar, India
--Navrang Oza--

Having 13+ years of experience in Odoo, Magento, Wordpress, Android, PHP Expert.

Skype : acespritech

Email : info@acespritech.com

Navrang Oza
12/10/18, 5:47 AM

In Mac, i found same issue and solve by this command,

pip3 install libsass==0.12.3

0
turki makki
10/8/18, 9:37 AM

Hello you can follow this video , it show you how to resolve the problem step by step

https://www.youtube.com/watch?v=s4ygbFH58h8

0
Mustufa Rangwala
10/8/18, 1:33 AM

Hi,

You can see here http://crocodillon.com/blog/how-to-install-sassc-and-libsass-on-ubuntu it should help

Regards,

Mustufa Rangwala

0
Avatar

Cybrosys Techno Solutions Pvt.Ltd

--Cybrosys Techno Solutions Pvt.Ltd--
Cybrosys Technologies
https://www.cybrosys.com
7702
| 6 5 8
Calicut, India
--Cybrosys Techno Solutions Pvt.Ltd--

Cybrosys Technologies is a private limited ISO certified company in Technology and Software Engineering sector. We serve as one of the best and trusted Odoo official partner, providing ultimate Customization and Implementation services in Odoo ERP. A frequent contributor to Odoo Apps, our customized free apps are downloaded by more than one lakh users. Most of our apps augment the potentialities of Odoo and are trending in the Odoo app store.

Cybrosys keeps privilege to be one among the finest Odoo Official Partners with 200+ free apps contribution towards the Odoo community. Cybrosys also stands number one in Odoo-social Media Integration empowering every kind of business solutions.

We are also enriched with highly skilled UI/UX technical experts for Developing, Implementing and Designing, thereby providing ultimate benefit to our customer base.

Today Cybrosys has reached par excellent in Odoo Implementation and allied services, proving its credibility and reliability. Our proven services are used by customers sprawling across 160+ countries including Middle East, African continents, UK, Germany, Spain, Thailand, Hong Kong, New Zealand, Australia, Malaysia, Singapore, Egypt etc.

We are rapidly expanding our base with robust quality management and business process re-engineering to meet the ultimate customer desire.

To know more about Cybrosys Technologies and our Odoo Apps, Kindly visit:

Cybrosys Technologies 

Odoo Apps 

And inbox us your queries to odoo@cybrosys.com

Cybrosys Techno Solutions Pvt.Ltd
9/11/18, 4:15 AM

Hi,

Install the package libsaas

Thanks




3 Comments
Divya Vyas
9/11/18, 4:27 AM

can you give me command for that ?

Cybrosys Techno Solutions Pvt.Ltd
9/11/18, 4:44 AM

Try sudo pip install libsaas

Divya Vyas
9/14/18, 3:36 AM

AttributeError: module 'sass' has no attribute 'compile'

getting this error after installing libsass

0
Avatar

Mitul Shingala

--Mitul Shingala--

2294
| 5 3 7
Rajkot, India
--Mitul Shingala--

Odoo Developer

Mitul Shingala
10/8/18, 2:20 AM

hello 

go to odoo directory, execute below command in terminal

sudo pip3 install -r requirements.txt
0
Yogesh
10/6/18, 9:58 AM

sudo apt-get install python3-pip 

pip3 install -r requirements.txt (make sure you set path of odoo 12.0 directory)

Ask a Question
Writer
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now