Odoo Help

0

How to increse the record limit for one2may field(7.0 v)?

By
syam sundar singh
on 2/24/15, 1:01 AM 786 views

As i noticed our system by defult its displaying the record limit as 80. And i able to change the limit for list view, but in case of one2many how can i change the limit of record?? can anyone suggest me?

when i change the limit in dropdown i unable to see Excel option.. and the excel option must visible in all cases when i change the limit also..

 

 

 

1
Akhil P Sivan
On 2/24/15, 1:52 AM

Hi,

Goto Settings >> Technical >> Actions >> Window Actions

Search for the action related to the tree view you want and open that.
In General Settings, under Filters you can give the Limit. (Default: 80)

From backend, you can add this to the view file. Add the following in the corresponding action definition.

For eg:
<record id="action_id" model="ir.actions.act_window">
    <field name="name">Products</field>
    <field name="type">ir.actions.act_window</field>
    <field name="res_model">product.product</field>
    <field name="view_type">form</field>
    <field name="limit">150</field>
    <field name="view_mode">tree,form</field>
    
</record>

Hi i been through the instructions befor but i need to change the line items. If the line items is above 80 records, we able to see Excel option. If i select more than 80 records in dropdown i unable to see Excel option.. can you please suggest me. Thankyou .

syam sundar singh
on 2/24/15, 4:12 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 2/24/15, 1:01 AM
Seen: 786 times
Last updated: 3/16/15, 8:10 AM