Odoo Help

0

How to have invoices in another language?

By
Victor Manche
on 9/7/14, 9:49 PM 1,622 views

My Odoo is set in Spanish, as i'm working in Panama.

The problem is that when I go to print/PDF my invoice (or other documents), it comes out  in English. But when i created it in the software it's all in Spanish.

I put Spanish in all the settings but still..

Are you using odoo v8rc1?

Stephen Mack
on 9/7/14, 10:07 PM

Version 7

Victor Manche
on 9/9/14, 5:34 PM

So the on-screen text is fine. It's only the printed version of your documents? Please list specific modules/reports that fail. Thanks.

Stephen Mack
on 9/10/14, 10:43 AM

Exactly. It happens with all the modules I use (Sales , Accounting, Purchases...)

Victor Manche
on 9/10/14, 11:10 AM
1
Michael St-Georges
On 9/10/14, 2:19 PM

Is your client set to be spanish? The printed versions are set according to the client's language and not the user's

Hi Michael, I search how to configure "client"s feature but couldn't found it. I changed the language in the "account section" but I have still the problem. Can you guide me with this?

Victor Manche
on 9/10/14, 4:25 PM

The language is set in the sales and purchase tab of the client. (I believe it has to be in the invoicing contact). Also, if you modify the original reports, you have to make sure the new terms appear in your translated terms.

Michael St-Georges
on 9/10/14, 10:10 PM

THANKS Michael you are right, it worked! I just wonder if there is a way to change this settings for ALL the clients, or if I have to do it manually one-by-one...

Victor Manche
on 9/11/14, 10:46 AM

THANKS Michael you are right, it worked! I just wonder if there is a way to change this settings for ALL the clients, or if I have to do it manually one-by-one...

Victor Manche
on 9/11/14, 10:46 AM

An easy way would be to export the clients with the language field and then edit them through excel and then re-import them. That's what I usually do for mass modifications.

Michael St-Georges
on 9/11/14, 10:59 AM
0
Stephen Mack
On 9/7/14, 10:17 PM

Sounds like you have this v8rc1 bug that has been reported to odoo in GitHub.

Thans for your answer, Actually I have this screen in Spanish, it is when I print it that comes out in English... I use the free browser version of Odoo.

Victor Manche
on 9/7/14, 11:09 PM

what is the free browser version?

Stephen Mack
on 9/8/14, 5:52 AM

Actually I checked and i'm using version 7

Victor Manche
on 9/10/14, 10:25 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 9/7/14, 9:49 PM
Seen: 1622 times
Last updated: 3/16/15, 8:10 AM