Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


How to handle currencies missing issue

on 5/7/13, 2:52 AM 2,520 views

Hi All, seems my currencies lost entirely for no reasons, any one can help to sort out what happened for that?

Before I have four currencies there, but right now I lost them totally.

image description

Hope my question is clear for you, thank you so much!

After I try to upgrade base module, I found I can not do it because:

image description

I tried to create a currency, because the original currencies are all gone, but I can not and with below warning, implies old currencies should still there but have no idea where they are:

image description

Hi, Brenda.li, have you already solved this problem? I came across the same problem with you these days. If you have solved this or had some suggestions, could you reply me? many thanks!

on 9/10/13, 2:47 AM


| 5 4 7
Baarn, Netherlands
On 5/7/13, 4:48 AM

The errormessage is about openERP being unable to find the currency rate for the given date or period.

The solution is to make sure there is a currency rate for the given date/period. This might be accomplished by upgrading your installation of openERP (upgrade base as Keyur mentioned), or you can manually create a currency rate for a period (Accounting -> Miscellaneous -> Currencies; click on the currency you want to change; Click on the button 'Edit'; click on 'Add new Item' at the bottom;type a correct date and the rate you want to use; click in the button Save)

Hi Patrick, I can not upgrade base module which Keyur mentioned because my database has some purchase order....records. And I can not manually create a currency (with currency rate) because the original ones are all gone, it is blank there, and i can not create with the warning(screenshot showed in my question) as well.

on 5/7/13, 5:37 AM

It worked for me. After disable the "base" checkbox I could add custom period

Damodar D.
on 10/5/15, 6:34 PM
Luis Leiva
On 11/19/15, 8:58 AM

I ran into this problem recently.  I haven't been able to fix the "no currency rate associated..." error but found a workaround I can live with.  Very simple, to daily change the currency rates just press OK to the error window and, although there are no currencies shown, you can just search for the currencies you need in the search bar and then they will appear in the list view.

Dharmesh Rathod
On 5/7/13, 4:31 AM


Currency is already there in your database. You have defined currencies and used them but currency rate is not there so it is not able to calculate amount.

You can fix this by updating value into database also.

Email : info@acespritech.com
Skype : acespritech
Blog : acespritechblog.wordpress.com

Hi Dharmesh. I think there are some restrictions in version 7.0, currency record can't be created directly from web client. The Current Rate field in currency form view is set to '0' by default and it is readonly. So is it the proper way to change directly in database every time we get error like this?

on 5/7/13, 4:48 AM

There is no restriction in OE 7 and rate fields be always editable otherwise it will never possible to update new rate for currencies.

Dharmesh Rathod
on 5/7/13, 4:57 AM

Hi Dharmesh, I did set up currency rate before, and the amount can be calculated by the rate i set. The situation now is I lost my old currency records(with their own currency rates) entirely, and now i can not upgrade base module and create currency.

on 5/7/13, 6:00 AM


| 4 4 8
Ahmedabad, India

Odoo Expert

On 5/7/13, 2:58 AM

Try to upgrade your base module. By that way you may have currencies back.

Yes? You means upgrade the version to the latest one(I am using version 7.0-20130327-002325 right now)? Because I tried to create one currency(assume it was deleted itself) and system said you can not do that because unique code reason. so i think it implies the currencies should still there in system but somewhere I do not know.

on 5/7/13, 3:21 AM

Here I've got the same problem when I create new currency record. Current rate is already set to 0 and readonly field so we can't create our currency that way. The problem is solved by discarding the changes or reloading the page. Even if there are any issues then try to upgrade base module in settings->Modules->Installed Modules->Base.

on 5/7/13, 3:55 AM

Thanks but I can not update the base module. the screen shot of warning notes is as above in my question.

on 5/7/13, 5:29 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 5/7/13, 2:52 AM
Seen: 2520 times
Last updated: 11/19/15, 8:58 AM