Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to fix `uom_id` failed against a constraint:

By
Brandon Gay
on 6/3/15, 1:43 PM 674 views

When I go to add a product, I get the following error:

`uom_id` failed against a constraint: Error: The default Unit of Measure and the purchase Unit of Measure must be in the same category.


I have not been able to figure out how to resolve this. - The units are the same in both the information and procurements tabs.

Odoo Version 8.0-20150522

This is a tricky one to troubleshoot and may have something to do with your configuration. Are you using the out-of-the-box units of measure and units of measure categories?

John
on 6/5/15, 11:28 AM

I did. I was using units. I then tried to put in a new one for pc(s) and try that. Same result.

Brandon Gay
on 6/5/15, 12:44 PM
0
Brandon Gay
On 6/5/15, 12:44 PM

I did. I was using units.  I then tried to put in a new one for pc(s) and try that. Same result.

I got this fixed. I had the portal user checked. Unchecked, and it works now.

Brandon Gay
on 6/5/15, 1:11 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 6/3/15, 1:43 PM
Seen: 674 times
Last updated: 6/5/15, 1:11 PM