Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


How to export and Import All the CRM work ?

Manos A.C.
on 2/26/15, 3:12 AM 971 views

Basically, im testing Odoo at the moment and would like to see how is it possible to import all the " Leads " " Customers " section

if possible the " Schedulled calls " and " Logged calls "

Do i have to log as administration and give some privilidges ? or its by default possible to import and export ?

Where is the field that i can import and export ? cant find it , i did manage to find some export field however not the fields that i mentioned above ..... i think i exported the users ..... would appreciate to get like a step by step import /export guide :)

Finally, once i export and then import leads, customers info, on the export will get them perfectly formated as it was before ? or i would have to re-adjust the database ? i would say that the import would be just the way it was before .

Please advise , much appreciated.

Would prefer to get non scrypted answers or coding, just GUI guide thanks :)

PS : i guess the excel format or CSV doesnt matter.



| 7 7 8
Turnhout, Belgium

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

On 2/26/15, 3:23 AM

Hi Manos

About a week ago I migrated over 3.000 leads from V7 -> V8 through CSV.
CSV is a great way to export and import data but it requires a lot of patience.
The idea is that you simply export alle records from your current Odoo by selecting them in the tree view and then click on more > export. This will look like this:

A new menu will now pop up where you can choose which fields you would want to export. Choose the fields you want, every field you've chosen for export will show up on the right side like this:
In this sample screenshot I would only export the subject when I would click on 'Export To File'.

The choise is yours really, but there are some fields (such as subject) that you will always need (the fields that have a blue-ish colour are needed). I'd suggest you to export a few records (like 5 leads) just to give it a test run.
The second step is to login on your new Odoo. You go to sales > Leads and click on 'Import' there. Choose your CSV file and then see if all the column titles match up. Give the import a try with 'Validate', if this succeeds you can finally import them! If it does not you will get errors which tells you what is wrong.

The concept of importing and exporting is the same for about everything in Odoo. It just requires quite some testing and patience, but you'll get better in it gradually. To answer your last question about the perfect format.. The format should match up perfectly, if you choose the correct fields.

Best of luck and if you need more help just let me know!

Manos A.C.
On 2/26/15, 4:08 AM

Hi Yenthe,

Much appreciate regarding the screenshot, everything is clear, however i have one problem....

i cannot see the " more " field, i tried logging in as " administrator " to see maybe that was the reason but still nothing ! i really wanna get there where you got in order to import / export, seams very straight forward however do you have any idea why i cannot see the " more " field ? do i have to like set a privilige for that in some kind of back end in the software ? im troubleshooting as we speak to check it out, maybe is it the free testing version does not include that >? do i have to download a new module for that ? please advise .

Hi Manos the only thing I can think of is that you haven't enabled the technical features for the admin user. Go to settings > Users and open up the admin account. You'll see one option here that is named "Technical Features" (under the title usability) check this on and save it. You should then see the more options..

on 2/26/15, 4:32 AM

Omg, im gonna laugh so much, the problem was that i wasn't selecting the " Box Fields " ! you know, the " more " field ( label ) is not available on default, once you select the " box fields " and click on few " leads " then the " more " field appears in order to get the export ! i have tested the " technical Features " enabling and disabling it and its the same thing, Yenthe you made my day ! thanks, gonna test now the import export as your previous post and move on ! Hope you have a great day m8 !

Manos A.C.
on 2/26/15, 4:43 AM

Its great to hear that you've got things working now! Lets hope the export/import goes easy for you. Please also accept my answer if it did help you? :) By the way if you run stuck on something else when importing just let me know.

on 2/26/15, 4:58 AM

I tried to " convert as an answer " however i dont have enough Karma to do so .... it requires 500 karma :( unless you meant me doing something else ?

Manos A.C.
on 2/26/15, 5:05 AM

ok ok got it, i think its the green " tick " Done ! :)

Manos A.C.
on 2/26/15, 5:07 AM

Thank you very much :D Well best of luck with the exporting!

on 2/26/15, 5:11 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 2/26/15, 3:12 AM
Seen: 971 times
Last updated: 3/16/15, 8:10 AM