Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


How to edit/add translations?

on 3/13/13, 4:32 AM 8,090 views

For a client I have set up OpenERP V 7 in German.

I would like to translate some termes in the OpenERP main panel from English to German. Like>Sales (Verkauf)-> my Follow-Ups (Verfolgen).

There are a few more like when I create a Sales (Verkauf) -> Inquiery (Anfrage) and fill in /create a new customer All the fields are in english not in German. Example: Steet, Country, State, Should be Strasse, Land, Bundesland/Kanton.

Where can I edit these?

Well it is strange that your form and main menu are not translated they should be translated in German by default. Ensure that you user lang is in german under the pref panel. You can also try to relaunch settings - Translations - Applications Terms - Load a translation. If your server is in multi process mode you should restart it.

Camptocamp SA
on 3/13/13, 9:53 AM

Well, most of the items are, there are just a few (Like my follow-ups,etc) that aren't. The problem is that my clients English is very bad, so he will want everything in German.

on 3/13/13, 10:06 AM

I have looked at that as well. Under Settings->languages I also have English deactivated.

on 3/13/13, 10:07 AM

Nicolas Bessi

--Nicolas Bessi--
| 5 7 8
Lausanne, Switzerland
--Nicolas Bessi--
Nicolas Bessi
On 3/13/13, 4:57 AM

You can edit translations under settings -> Translations -> Applications Term ->Translated Terms.

From here you can manage all your translations. Please refer to the documentation for more infomations:


Be also aware that the modification of an existing translation will be reseted if you update your addons. You may create your own PO files.

Kelly Stuart
On 7/9/13, 10:02 PM

You can find the name of the field by following these steps. First, make sure you are in Debug/Developer mode by choosing "About OpenERP" from the menu that appears when you click on your username in the upper-right corner of the screen. Now navigate to the form that contains the field in question. Hover your cursor over the label of that field to view its info. In the contextual help balloon, you should see the field name listed.

If your translations continue to not show up, try going to Settings -> Translations -> Application Terms -> Synchronize Terms.

Please let me know if this was helpful or if you continue to have problems.

For me, the Synchronise Terms solved the problem.. I've tried to import the .po file but it didn't change anything. I was updating the module and in the server window it was writing that the translation was still missing. Thank you!

Michael O. Lambert
on 3/5/14, 3:00 PM

You are very welcome, Michael. I'm glad to help when I can.

Kelly Stuart
on 10/30/14, 1:48 AM


Akram's answer here is helpful follow the steps and use --update=all flag when you update the module. That worked for me.


On 4/13/15, 5:16 AM

There is a real problem, every time when I synchronize the terms (Translations->Application Terms->Synchronize Terms) there is a duplication of all the translated words in (Translated Terms). I tried to :

1- load the transaltion from po file (Translations->Load a Translation) with the option "Overwrite Existing Terms"

2- synchronize terms

But no solution ?

idem here. Real problem with this duplication. https://www.odoo.com/forum/help-1/question/why-does-synchronize-terms-duplicate-those-lines-in-ir-translation-93807

Pascal Tremblay
on 11/24/15, 4:19 PM
On 3/13/13, 5:12 AM

Thank you, I tried that: You can edit translations under settings -> Translations -> Applications Term ->Translated Terms. I go to create and add source= My Follow-Ups, Translation= Zu Verfolgen, Lang= German. What I can't figure out are fields: Translated field and Type. The link you gave is not very infomative for someone with little experience in DB's. Any suggestions?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 3/13/13, 4:32 AM
Seen: 8090 times
Last updated: 4/7/16, 8:35 AM