Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

How to disable Human Resource access to a user?

By
Pascal Tremblay
on 2/19/15, 10:21 AM 1,473 views

Hello guys!

When I edit a user in my Settings, it is impossible to remove « employee » from Human Resource... How could I delete this access. THis user is not a employee and I don't want him to see « Human Resource » menu in the menubar.

Thanks

« Employee » always stays set when I save.

Pascal Tremblay
on 2/19/15, 10:22 AM

When a user has Sales group, he gets imperatively Employee group. When I remove Sales access, I can remove Employee group

Pascal Tremblay
on 2/20/15, 5:49 AM
1

Cyril Gaspard (GEM)

--Cyril Gaspard (GEM)--
4136
| 5 6 8
Paris, France
--Cyril Gaspard (GEM)--

Forum contributor since 2008

Cyril Gaspard (GEM)
On 2/19/15, 8:33 PM

Hi,

1) create a new group group_user_new

2) For menu menu_hr_root, remove group  base.group_user and add group group_user_new in groups attribute

3) for group base.group_hr_user, implied_ids the group group_user_new (group roup_hr_user, will inherit group group_user_new)

4) Add users you want who can see the top menu human resources to the group group_user_new

Bye

Thanks to you for your nice answer. I have learned many things! The right things.

Pascal Tremblay
on 2/20/15, 7:59 AM
1
Shawn Varghese
On 2/19/15, 10:26 AM

Go to Settings/Groups and search for Human Resources. Try removing the user from there. It worked for me.

For the moment, it works. The « employee » setting is disapeared. But the user can not login anymore. Internal error.

Pascal Tremblay
on 2/19/15, 10:38 AM

There is some relation (access right) with im_chat.presence. I will stay this user on « employee » for the moment.

Pascal Tremblay
on 2/19/15, 10:51 AM
0
Juan José Scarafía
On 2/19/15, 10:32 AM

Hi Pascal,

What you can do is to disable some options from the "Technical Configurations", such as assistance, time in task, etc, so the user can't use the Human Resources options.

Regards,

Juan José - Ing ADHOC

I prefer this one. I try your solutions. thanks guys

Pascal Tremblay
on 2/19/15, 10:33 AM

No, it doesn't work. Not the time I try this. Even if I uncheck all the user technical setting, human resource ALWAYS stay on « employee ».

Pascal Tremblay
on 2/19/15, 10:37 AM
0

Pascal Tremblay

--Pascal Tremblay--
1312
| 5 2 7
Alma, Canada
--Pascal Tremblay--


Pascal Tremblay
On 2/20/15, 8:03 AM

What I needed was to remove the group « Human Resources / Employee » in the groups of the « Human Resources » menu item.

This way, the managers and the officers of human resources can see the menu. The employee can not see the menu anymore. Perfect for us!

Big thanks all for your precious answers.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 2/19/15, 10:21 AM
Seen: 1473 times
Last updated: 5/13/15, 2:44 PM