Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

How to direct browser to port 8069 in v7?

By
Sean Samborski
on 12/19/13, 5:10 PM 2,401 views

I have installed on my server via the directions in the manual (can't post any links so hopefully you can just guess what I'm talking about.) After fighting with all the instructions that are written for v6.1 and not applicable for v7, I finally got it set up and running. Now I can get to my application using domain:port. Since I would like my application to reflect a URL without needing to specify the port, I need to find out how to do this.

I made the mistake of assuming the all-in-one included the web server, but I can't find any .conf files the OpenERP fake v7 doc (really a copy and paste from the v6.1 doc and relabeled v7 but that's another story.) So I have no apache, no nginx, no openerp-web and/or any web-server .conf files. I probably do but since we can't get any real v7 documentation it's probably all changed.

Can someone please explain how to fix this issue? Sorry if my message here sounds a bit ranty but I've paid for several support hours and I can't get in touch with the rep and have been told over the phone no one is available to help me with this today. I'm already under the gun.

wouldn't nginx just solve your problem? or any reverse proxy?

Eric
on 12/19/13, 10:47 PM

Maybe it would. But I could argue an all-in-one should handle that and not expect all users to be server admins. I don't know how to set up nginx. Would it interfere with what OpenERP is already doing? I don't know these things and I don't think using this application should require you have that knowledge.

Elephante, Sean Samborski
on 12/20/13, 12:00 AM
1

Daniel Reis

--Daniel Reis--
3436
| 6 7 9
Lisbon, Portugal
--Daniel Reis--

Author of the "Odoo Development Essentials" book.

Applications Manager at Securitas Portugal

Github: https://github.com/dreispt

Twitter; @reis_pt


Daniel Reis
On 12/20/13, 5:09 AM

You can have OpenERP responding on the standard HTTP, port 80. For that, set the xmlrpc_port configuration setting, but that requires some OpenERP Administration knowledge. But then, if you're hosting it yourself, that's a must - consider having some training on this.

Is short, there's two ways to do it:

  • Start the server with the --xmrpx-port=80 option.
  • Locate the .conf file your installation is using and add a xmlrpc_port=80 to it. This hasn't change from v6 to v7, so v6 documentation will give your proper guidance for this.
0
Lionel J
On 6/26/14, 8:46 AM

Go to the adress and then just add your server ip and then ":8069"

Like this :

ip_adress_of_your_server:8069

0
Pavel Pavlov
On 12/20/13, 5:19 AM

Hello,

If I understood you correct, your question is how to make openERP respond to http://<host>, on standard port 80, not default one 8069. Easiest way to do this would be via your config file. Here is an example how to do it, if you have no idea what to look for...

1)# ps -ef | grep openerp
openerp 2506 1 0 11:01 ? 00:00:01 /usr/bin/python /usr/bin/openerp-server --config=/etc/openerp/openerp-server.conf --logfile=/var/log/openerp/openerp-server.log

2)# vi /etc/openerp/openerp-server.conf
=>Set xmlrpc_port = 8069 to xmlrpc_port = 80

3) # /etc/init.d/openerp restart
Now your instance should be listening on http://<host>.

Regards,
Pavel Pavlov

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 12/19/13, 5:10 PM
Seen: 2401 times
Last updated: 3/16/15, 8:10 AM