Odoo Help

1

How to CSV-import products (product.templates) with a relation to their respective main suppliers in Odoo V8?

By
Maarten
on 3/6/15, 10:34 AM 1,594 views

All the suppliers are in de database. Now I am trying to import (via the normal csv import funcionality) all products into Odoo, and this, of course, linked to their respective suppliers (or rather: just one main supplier).

If I first export ("Import compatible export) one product record (not linked to a supplier) with minimal data (only product external ID and Main Supplier External ID), I get:

"id","seller_id/id"
"1008837",""

If I add the supplier to the product and do the same export, I get:

"id","seller_id/id"
"1008837","901088"

However, removing the supplier from the product and then importing the exact csv I just exported, doesn't link the product to the supplier. The csv validates allright and there are no errors during the import either. Still, the product is not linked to the supplier.

I tried several ways of linking the product to the supplier, for instance via:

Main Supplier / External ID
Products / Main Supplier / External ID
Products / Products / Main Supplier / External ID     (what does this mean, actually?)

Looking up the external identifiers via "Settings - Sequences and Identiefiers - External Identiefiers" shows that the external ID's are correct, both for product as for supplier.

I've tried with product variants as well, but that didn't work either.

This question is closely related to (or the same as):

https://www.odoo.com/forum/help-1/question/import-products-seller-ids-67310
and
https://www.odoo.com/forum/help-1/question/importing-products-with-supplier-info-27786

Thanks in advance!

0
michel Guénard
On 3/6/15, 1:02 PM

From my own experience

When importing products with their suppliers'names:

1. the column identification must be "Supplier / Supplier"

2 the suppliers' names must be spelled exactly as they are in your database (including low/upper case)

3 you must have (in your csv file) a column called "supplier / minimal quantity" where you key in the appropriate quantity (by default 1 or 0)

 

0
Maarten
On 3/7/15, 10:56 AM

Thank you, thank you, thank you! At last it worked!

This should be better documented! :-)

I am happy that you are happy:)You owe me some chocolates:)

AD LIBITOM, michel Guénard
on 3/7/15, 11:35 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 3/6/15, 10:34 AM
Seen: 1594 times
Last updated: 3/16/15, 8:10 AM