Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to configure Ubuntu 12.04 SERVER and Virtual Box to access Odoo from Host System

By
Malte Helmhold
on 5/23/14, 1:29 PM 5,712 views

Hi guys, this questions relates to André Schenkels answer on https://www.odoo.com/forum/Help-1/question/How-to-install-OpenERP-V70-on-Ubuntu-1204-from-launchpad-repository-2562.

But as you can see his anser did't really answered the question asked (because it related to launchpad). So I wanna move my one of my three questions here. (I would not delete the questions from the original post, because they directly relate to this). But this question has to be asked, because I'm new to Ubuntu Server, must know the answer and can't find the answer (or do not know where to search properly)

Question:

I'm using virtual box in order to configure Ubuntu 12.04 Server. I'm hosting Wordpress there, configured Port Forwarding for HTTP(8080/80), SSH(2222,22). So I configured the Apache Server in order to get access via Virtual box guest addition. And I can call wordpress from my host machine with: wordpress.dev:8080

but! How can I access odoo? what IP or DNS do I have to choose and how can I configure the dns? For wordpress in configured /apache2/sites-available/wordpress.dev

I'm not using ubuntu this long in order to deploy applications. So when everyone says http://[ip or dns name of server]:8069. What server is meant? The new odoo server and not the apache2 have running anyway right? 

So where do I get a dns for that?

Don't I have to create a port in virtual host (port forwarding)

(Because as I can see in the most Video tutorials on youtube most people use ubuntu desktop and after odoo installation they call odoo from their guest machine, what is boring in a way. Calling it from the host computer would be cooler)

1
Ben Olsen
On 5/23/14, 5:49 PM

First, in VirtualBox make sure that the host can see the guest system. The easiest way to do this is change Network settings to Bridged mode and make sure that Promiscuous Mode is set to "Allow All." (Sorry, I don't know what the German settings will be called, but hopefully that translates easily.)

Second, Odoo/OpenERP is a different beast than something like Wordpress. Keep in mind that OpenERP is its own webserver. So starting openerp-server is similar to starting Apache itself, and in this particular regard they are peers. You don't need to configure Apache to do anything (you can, I mean it's possible, but if you're just starting out, it's not necessary).

Also, it's not necessary to configure DNS. If that's confusing you, don't do it. It's not clear from your question, but I'm assuming that your new Odoo server is a different VM than your Wordpress server. I hope that's true, because trying to mix them might get confusing. So on your guest Ubuntu system, the new one for Odoo, if you type this command:

ifconfig eth0

It will show you the primary virtual network controller and what IP address it got. That's the IP you want to use in:

http://[ip of server]:8069

If "ifconfig eth0" doesn't work, you can do "ifconfig -a" to show all network controllers. 

Once you get used to working with Odoo, there are options for setting it up to run with nginx and gunicorn, which makes it more like a normal web server, but you DON'T need to do that initially. The openerp-server command itself will run its own web server.

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/23/14, 1:29 PM
Seen: 5712 times
Last updated: 3/16/15, 8:10 AM