Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to change the time Zone in openerp?

By
samba
on 7/30/14, 6:37 AM 3,748 views

Does it possible to maintain more than one time zone using one server in openerp?. I have added two users "admin" with "Asia/Kolkata" and "admin1" with EST. I have login with "admin" it is showing "08/26/2014 20:01:49", and i have login with "admin1" for this user also it is showing "08/26/2014 20:02:05" same time. How can i overcome this? Is it  possible to change time zone for a database? this also give solution to my problem.

0

Atchuthan - Technical Consultant, Sodexis Inc

--Atchuthan - Technical Consultant, Sodexis Inc--
3918
| 5 3 8
Puducherry, India
--Atchuthan - Technical Consultant, Sodexis Inc--
Passionate coder in Python/Odoo(formerly known as OpenERP).

Contact me via GMail: atchuthantu@gmail.com via Skype: atchuthan_skype
via Linkedin: http://in.linkedin.com/in/atchuthantu
Atchuthan - Technical Consultant, Sodexis Inc
On 7/30/14, 6:56 AM

Yes, If you have 2 or more users and for each user, we could set their respective time-zone.

How can we set?

samba
on 7/30/14, 7:43 AM

Go to User menu from Settings/Users/Users, select your user and in the Preference page, you can see the TIMEZONE field. Choose your needed TZ there

Atchuthan - Technical Consultant, Sodexis Inc
on 7/30/14, 8:02 AM

Thank you atchuthan, does it working properly to you, when change in user preferences? . To me its not working properly. but It's not working. Even though i have changed time Zone to us/pacific, it is showing current my system time zone. My time zone is Asia/kolkata time 15:10:00 . It is showing as it is 15:10:00 . Am i need to change any configurations ?

samba
on 7/31/14, 2:48 AM
0
Mariusz Mizgier
On 7/30/14, 7:20 AM

Just click on your username in the right upper corner, select preferences and choose desired timezone.

Thank you Mariusz Mizgier , but It's not working. Even though i have changed time Zone to us/pacific, it is showing current my system time zone. My time zone is Asia/kolkata time 15:10:00 . It is showing as it is 15:10:00 .

samba
on 7/30/14, 7:40 AM

I have little confusion. time showing 15:10:00, but when i see the database record, it has 11:30:31. Why this difference. But when i see this record in list it is showing 15:10:00.

samba
on 7/30/14, 7:43 AM

It is caused by the server - it stores record in database with GMT datetime and shows the record to the user with their current timezone.

Currenda Sp. z o.o., Mariusz Mizgier
on 7/30/14, 10:46 AM

Thank you Mariusz Mizgier, does it working properly to you, when change in user preferences? . To me its not working properly. Am i need to change any configurations ?

Currenda Sp. z o.o., Mariusz Mizgier
on 7/31/14, 2:55 AM

Yes, it is - I'm in GMT +1, so it shows all the times correctly.

Currenda Sp. z o.o., Mariusz Mizgier
on 7/31/14, 2:56 AM

I have tried with different time zones, for me its not working. I am using latest version of server and addons.

samba
on 8/2/14, 11:34 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 7/30/14, 6:37 AM
Seen: 3748 times
Last updated: 3/16/15, 8:10 AM