Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to change the limit of 80 of the fields in a model view?

By
Pascal Tremblay
on 5/29/16, 5:06 PM 393 views

hello there,
 

I would want to change the limit of 80 in the fields list here.

thanks to help


EDIT #1

The list of fields is defined in the view base.view_model_form. In the XML, we have this code. Can we define a limit in a XML file?

                        <page string="Fields">
<field name="field_id">
<tree string="Fields Description">
<field name="name"/>
<field name="field_description"/>
<field name="ttype"/>
<field name="required"/>
<field name="readonly"/>
<field name="select_level"/>
<field name="state"/>
</tree>
<form string="Fields Description">
<group col="4">
<field name="name"/>
<field name="state"/>
<field name="field_description"/>
</group>
<group string="Properties">
<group>
<field name="ttype"/>
<field name="relation" attrs="{'required': [('ttype','in',['many2one','one2many','many2many'])],'readonly': [('ttype','!=','one2many'), ('ttype','!=','many2one'), ('ttype','!=','many2many')]}"/>
<field name="relation_field" attrs="{'required': [('ttype','=','one2many')], 'readonly': [('ttype','!=','one2many')]}"/>
<field name="selection" attrs="{'required': [('ttype','in',['selection','reference'])], 'readonly': [('ttype','not in',['selection','reference'])]}"/>
<field name="size" attrs="{'required': [('ttype','in',['char','reference'])], 'readonly': [('ttype','not in',['char','reference'])]}"/>
<field name="domain" attrs="{'readonly': [('relation','=','')]}"/>
<field name="serialization_field_id" attrs="{'readonly': [('state','=','base')]}" domain="[('ttype','=','serialized'), ('model_id', '=', parent.model)]"/>
</group>
<group>
<field name="required"/>
<field name="readonly"/>
<field name="select_level"/>
<field name="translate"/>
<field name="on_delete" attrs="{'readonly': [('ttype','!=','many2one')]}"/>
<field name="modules"/>
</group>
</group>
<separator string="Groups"/>
<field name="groups"/>
</form>
</field>
<button
icon="gtk-justify-fill"
name="%(act_menu_create)d"
string="Create a Menu" type="action"
target="new" />
</page>

1
Edser Solis
On 5/29/16, 5:50 PM

If you mean the quantity of items displayed simultaneously on the list just try double clicking on it. It will give you various options. 

yes I know this. But I want to change it permanently.

Pascal Tremblay
on 5/29/16, 5:56 PM
0
Juan Vicente Pascual
On 5/30/16, 2:46 AM

You have to activate developer mode, then select "edit action" from the dropdownlist, there is a field called limit, there you can change it.


Kind Regards.

thanks. But I have already done it .It changes de limit of the ir.model view. Not the limit of the fields in a particular ir.model form view.

Pascal Tremblay
on 5/30/16, 9:51 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/29/16, 5:06 PM
Seen: 393 times
Last updated: 5/30/16, 10:17 AM