Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

How to change the currency of the company and apply this to new quotations and invoices?

By
Acar Nila
on 3/23/13, 2:42 AM 18,804 views

I have installed only Sales Management Module in OpenERP and using "custom" accounting option with default currency (EUR).

After that I change the Company Address to other country using different curency e.g Unites States (USD).

I found that in Quotation and Sales Order it still used EUR currency while in the Invoice it changes to USD currency. How to fix this ? I want to change to USD as the default currency.

3
Acar Nila
On 4/13/13, 1:35 AM

After doing so many trial and error it seems that multi currency in OpenERP is a wiered things to tame. I got this fact :

By default OpenERP use EUR as internal default currency, no mater how you change your company default currency, internally OpenERP still reference EUR as the default currency.

Doing a "Settings --> Configuration --> Invoicing" and change the "default company currency" to other currency doesn't mean that you change the EUR reference OpenERP use internally. It just change the currency symbol on your form, report, and the document you print.

If you don't plan to use multi currency feature this is fine. But if you plan to use multi currency feature after you change your default company currency from EUR to others currency, let say for IDR, and then you add another currency (USD as an example) by adding some account and bank account on those currency (USD) you will get wiered number on your journal and account. OpenERP will convert the number on other currency (USD) according to the rate of those other currency to EUR not to your default company currency (IDR).

So if you plan to use multi currency feature and your default company currency not EUR you must change the rate of your default company currency to "1" first before doing any transaction, don't do it in the middle of your fiscal year or you will screw up your accounting numbers.

No need to change the currency rates, see my answer.

patrick
on 4/24/13, 12:23 PM
2
Abhishek
On 3/23/13, 4:14 AM

Hi Acar,

Perhaps you have not defined other Pricelist(USD)in proper way so its not coming to invoice page. If you want to use USD currency to moves on invoice page then define its pricelist and pricelist version too. (follow SALE >> configuration >> Pricelist)

Or if you just want to set USD as your default currency. Then change your company currency. (follow SETTINGS >> Companies >> Your Company >>) open your company form and then open configuration tab >> and define Currency.

Hope it will help.

With basic Sales Managemen module instalation the "price list" menu is not available. We can get this menu available after whe activated the "Technical Features" from the "Access Right" tab of user settings and then checked the "Sales Price Lists" item which is some how an advanced topic for the beginers. The second paragraph of your answer is actually my question. After doing that you will find that the quotation and sales order form still used the old currency and the invoice form change to the new currency set in "Your Company". Please check and try it first !

Acar Nila
on 3/26/13, 12:01 AM

Thanks abhishek

Amar Ranjane
on 5/18/13, 11:30 AM
0
Glenn
On 4/28/15, 2:27 PM

I had the same problem where I set the default currency to USD but quotes we're always in EUR. I finally figured out that you need to go to settings>invoicing and set your chart of accounts. This changed everything to USD. Don't leave it default.

0
Mohamed Hagag
On 12/6/14, 6:03 PM

Ok, Although this is more than a year old, but till now Odoo8 still have this strange behaviour like @Acar said in Multi-currency with Eur not set as main cur.

Odoo sets your main currency to rate of 1 even if you set its rate to other value.

for ex. I set the main cur to EGP, and I've multi-currency if i switch a customer invoice currency from EGP to Eur I get the same values, while it should 9 times more.

if i switch to from EGP to USD it treats EGP with the value of Eur and 10 EGP = 12.5 USD which is the rate of Eur not EGP.

As a workaround you must set the main currency (EGP)  rate to 1 and calculate other currencies rates in relation to EGP including Eur.

 

0

patrick

--patrick--
1958
| 5 4 7
Baarn, Netherlands
--patrick--
patrick
On 4/13/13, 8:21 AM

Under the account department, you can specify which currency is the default. You have to enable multi-currency from settings -> Accounting -> Enable multi currency; and you have to enable technical features on the user (settings -> Users -> double click on the user -> 2nd tab).

From now on, all prices are expected to be in the new default currency. When selling your product (or service) in another currency, it will be converted, using the rate defined.

Answer?!

The default currency is specified oin the following way:

  1. Accounting -> Miscellaneous -> Currencies
  2. Search for your currency and click on it
  3. Click on the button Edit
  4. Tick the square behind the text 'base'

From now on, the prices are by default in the new currency (so Eur 5 changes to US$5 for example).

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 3/23/13, 2:42 AM
Seen: 18804 times
Last updated: 8/3/16, 1:12 AM