Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

How to change LISTENER of ODOO

By
Drees Far
on 9/10/15, 5:29 AM 553 views

Hello!!

I want to change the listener 8069 of ODOO to 8070.

where can i find the file responsable of defining the listener please.

Is here any suggestion!!

Thanks a lot in advance.

Regards.

4

Yenthe

--Yenthe--
6696
| 7 7 8
Turnhout, Belgium
--Yenthe--

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

Yenthe
On 9/10/15, 5:37 AM

Hi Drees,

There are quite some options for this. You can provide the --xmrpc-port parameter in your command or the -c /etc/yourconfigfile.conf or use Apache/NginX to redirect the port.
For example with xmlrpc_port:

./openerp-server --xmlrpc-port=8080

For example with the -c parameter:

./openerp-server -c /etc/yourOdooConfigFile.conf

The -c parameter will call the configuration file which needs to contain the Odoo port.So in the file you should have this:

xmlrpc_port = 8080

Another option is to change the Python code but I wouldn't advise this.
Under /openerp/tools/config.py you can provide the Odoo port. In the file is a line like this:

 group.add_option("--xmlrpc-port", dest="xmlrpc_port", my_default=8069,

You can change this to the port you wish.

Yenthe

0

Drees Far

--Drees Far--
1130
| 5 2 6
Tunis, Tunisia
--Drees Far--
Drees Far
On 9/10/15, 5:32 AM

Find it easily :)

in the openerp_server.log

I have added xmlrpc-port=8070 option in my opener_server.conf and its working well.

Thanks.

@Drees check out my answer with all options. Of all the options you have this is probably the worst. This is not future/upgrade proof if you ever update your Odoo code. And its not clean since you're editing original source code files from Odoo.

Yenthe
on 9/10/15, 5:38 AM

Sorry, but why did you put -1 to my answer and -1 to my question????

Drees Far
on 9/10/15, 5:52 AM

Here is from wher i have got the answer: https://www.odoo.com/fr_FR/forum/help-1/question/how-to-change-the-default-port-8069-used-by-odoo-server-60679 and it functions very well so why ??

Drees Far
on 9/10/15, 5:54 AM

@Drees I didn't, somebody else did. To the person who downvotes this question and his answer: why? This was a valid question. @Drees I'll upvote it so it puts you at 0 again atleast. I can't do more.

Yenthe
on 9/10/15, 5:55 AM

No, i have asked you because i have found an answer which wans upvoted 3 times. I am so sorry my friend

Drees Far
on 9/10/15, 5:56 AM

pleased to talk to you @Yenth :)

Drees Far
on 9/10/15, 5:58 AM

Thanks Drees, great to hear! :) Hope this showed you some more insight about the xml-rpc port!

Yenthe
on 9/10/15, 7:49 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/10/15, 5:29 AM
Seen: 553 times
Last updated: 9/10/15, 6:44 AM