Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

3

How to avoid sending notifications per Email?

By
Francisco Bustamante
on 2/20/13, 9:31 AM 14,791 views

Can the notifications be prevented from being sent as email?

At least at this point in time, unless something is explicitly sent as email, it should not be sent to the partners in particular. (we also have not activated the user portal at this time).

Thanks in advance!

4
Scarlet Vacaru
On 3/25/13, 11:30 AM

I also had the same problem with email notifications to customers. Situation: I created a Quotation, then I Confirmed the sale. When confirming the sale, the customer was being sent an email to follow the document. And that was bad for us. I deactivated the Customer Portal and now it's alright, customers are not notified anylonger. For anyone new to Openerp 7.0, the path is: Settings/Configuration/General Settings - Portal Acces - then check or uncheck the "Activate the customer portal" button. You might give a second look to see whether the customer portal is activated or not. In my situation, I thought it might be something related to social networking or to followers, but it was a false trace. Anyway, activating the customer portal has its logic: they are for sure notified when the portal is active.

4
Yann Charlou
On 12/31/13, 4:21 PM

You can easily mass change "notification_email_send" for all existing customers this way :

  • CSV export all your customers
  • Change quickly the column "notification_email_send" (or add it if not in you csv) to "Never"
  • remove all columns except "id" and "notification_email_send"
  • Import you csv back to Openerp.

Then you can change the default value to prevent new customers being notified.

  • Go to the customer form view
  • Clic on top right on your name > "about openerp" > activate developer mode
  • You will see a new dropdown just before the form title. Select "default values".
  • Set your default value for notification. Choose "all users".

Note : I'm using Openerp V7 in french. Texts may be slightly differents. Hope this help.

4

Andreas Brueckl

--Andreas Brueckl--
5056
| 7 8 7
Vienna, Austria
--Andreas Brueckl--
OpenERP Consulting and Development
Andreas Brueckl
On 2/20/13, 9:44 AM

You can disable the notification for you in the "User Preferences" (top-right corner). Just set the field Receive Feeds by Email to another value than All feeds.

You can set the same field in the "Settings -> User" menu for other users.

I have disabled my notification preferences, but still everyone else receives notifications, in particular emails are getting sent to our sales@ address and to partners, without a clear indication why and how to disable those.

Francisco Bustamante
on 2/20/13, 10:00 AM

Where (in which module) do you have this problem? If you create a new Sales Order, then the partner is not automatically a follower. You have to add him, otherwise he want receive any notifications.

Andreas Brueckl
on 2/20/13, 10:15 AM

One concrete example: incoming emails are converted to leads. Emails received as leads are being sent to our sales@domain from the admin user address. The sales@ address is only an alias, not even partner or otherwise.

Francisco Bustamante
on 2/20/13, 10:52 AM

Sorry, but I can not follow your example. You can try to set flag "Opt-Out" in all your partners or just disable the outgoing email gateways.

Andreas Brueckl
on 2/20/13, 11:11 AM

I have set everyone to opt-out, and unsubscribed all users. Here is a specific example: 1) user sends email to partner from openerp 2) partner replies to email 3) partner receives an email from admin, with a copy of his reply. Step 3 is the one causing me headaches, why is admin sending copies of emails to everyone? Admin was not even involved in the document/discussion/at all!

Francisco Bustamante
on 2/22/13, 11:49 AM

I likewise have the same issue - every customer that sends an email to my account (emails that appear in the 'messaging' section OR any emails sent from openerp that are replied to by partners) are getting sent back to the customer/partner. This is of particular note to older emails that are are sitting on the email server that are then being fetched by openerp......

Oliver Stanton
on 2/26/13, 4:02 AM

Hi, we have the same problem. We use sales quotations and meetings. We would like to send emails to partners when we create an offer, but we do not want to send emails when we create a meeting. Is it possible to disable sending emails to partners for meetings?

erpnedir
on 5/1/13, 8:25 AM

Is there no GLOBAL setting?

FRACHT FWO CZECH
on 7/5/13, 8:33 AM
2
Juanjo Algaz
On 5/16/13, 8:53 AM

If it's for customers, you can configure on:

Customers --> Sales & Purchases --> Receive Messages by Email | Opt-out

When opt-out is checked, the customer dont receive more emails

I can not find this setting, is this for OpenERP 7? There is no path Customers --> Sales & Purchases --> Receive Messages by Email | Opt-out

FRACHT FWO CZECH
on 7/5/13, 8:33 AM

Open a partner, and on Sales&Purchases you could view this options. Maybe a access rights limit, try with admin with all access.

Juanjo Algaz
on 7/8/13, 9:48 AM
1
Alan Bell
On 6/30/15, 12:32 PM

I think this is broken so I filed a bug https://github.com/odoo/odoo/issues/7374 the problem is that if you change the notification preferences of the customer to not get the spammy notification stuff then they also don't get actual emails that you try to send them. 

1
IT Libertas
On 3/13/16, 6:16 PM

Perhaps, this module https://apps.odoo.com/apps/modules/9.0/internal_thread/ would solve your problem

0
Kalpana Hemnani
On 3/16/16, 5:59 AM

Francisco,

Go to Customer --> select customer for which you don't set off notifications --> Sales & Purchase --> Check Opt-out. This will defiantly work for you. By checking this option for selected customer won't get any notification mails.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

7 follower(s)

Stats

Asked: 2/20/13, 9:31 AM
Seen: 14791 times
Last updated: 3/16/16, 5:59 AM