Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


How to activate chat (im) in v8 (trunk)

Pablo Manuel Rizzo
on 6/26/13, 4:17 AM 14,337 views

I know its already answered that chat (im) is only available from v8, but I have trunk running and the im and im_livechat modules installed, I can create channels, and insert the code in my website, but the chat icon keeps saying "Instant Messaging is not activated on this server."

How do you activate IM?




| 5 3 8
Bogotá, Colombia
Informatics engineer Industrial engineer
On 7/3/13, 1:13 PM

First you need to install gevent

apt-get install python-gevent

Then install gevent_psycopg2 I installed this one


Then you need to start the server with --gevent

openerp-server --gevent

the server will be launched in port :8072

server helps mentions this about gevent option "Activate the GEvent mode, this also desactivate the cron."



now you have to launch the server with openerp-gevent not openerp-server --gevent

I start my server with sudo /etc/init.d/openerp-server start or sudo service openerp-server start. So would I need to replace openerp-server with openerp-gevent in this two commands? How would you incorporate the gevent option into that start script (that most of the times will be used) And what module exactly do you install? this one https://www.odoo.com/apps/trunk/im ?

on 8/2/14, 1:29 AM

here is a version that is meant to be for 7.0. https://bitbucket.org/anybox/web_im Will report whether that work once I have tested it.

on 8/2/14, 1:37 AM

Sudhir Arya (SA)

--Sudhir Arya (SA)--
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow




Sudhir Arya (SA)
On 6/29/13, 6:11 PM

I think you need to pass command line argument when you start OpenERP server from terminal. I don't remember what is the option you have to pass.

But I am sure chat will be activated when you pass the command line argument (option).

Try this but I am not sure this option is right or not. So just try it.

python openerp-server --addons ../addons/,../web/addons --gevent

Hope this will work.

Adding this parameter, the server listens on port 8072, but not on 8069, so it doesnt work

Pablo Manuel Rizzo
on 8/28/13, 5:40 PM

I have tested the latest #odoo v8.0 build (Ubuntu 14.04 with ODOO v8 install script). IM Livechat works out-of-the-box (on port 8069) without separate openerp-gevent service or any modification.



The --gevent option, run your OpenERP server with gevent. Gevent is based on eventlet. Evenlet use the coroutine not thread. So you open only one thread for all the connection, and the block loop, block all the coroutine, it 's dangerous.

If really you want use the gevent server, you must launch 2 OpenERP server: * the first with the OpenERP server on the 8069 port * A second with gevent server, on the 8072 port

Use a Apache or Nginx to dispatch between OpenERP server or gevent server (path /longpolling)

Hi Jean! As we would like to use the chat, We have run openerp trunk with gevent option but we find out that cron stops working. Any suggestion? Following your message we should lunch 2 oerp servers and then 'dispach' them whit gevent. Can you give some clues on how to achive this? Also, As you said "If really you want use the gevent server,...". Any problem with running gevent?

Juan José Scarafía
on 10/18/13, 11:58 AM

Jean-Sebastien, could you elaborate on what you mean? In what way is it dangerous to run openerp-gevent?

A. Person
on 1/27/14, 12:40 PM
On 5/26/14, 7:08 AM

Does this apply to V8/Trunk right now?

On 5/26/14, 4:18 PM

I was following all the instructions here and in other threads and nothing, but then I discovered that I need to:

1 - Activate the public user

2 - Set its password as 'public'

Then chat started working in the website and external websites :D

Ahmed Hassan
On 2/11/14, 2:17 PM

Pre Request for IM module: 1. # sudo apt-get install python-gevent 2.# apt-get install psycogreen 3.# pip install psycogreen-1.0.tar.gz 2. # easy_install gevent 3. # easy_install greenlet 4. # apt-get install python-all-dev 7.# apt-get install libevent-dev 5. # easy_install gevent-psycopg2-0.0.3.tar.gz 6. setup IM module 7. And run your server by openerp-gevent # ./server/openerp-gevent --addons addons/,web/addons & 8. use port 8072

@Ahmed Hassan, I have updated above provided commands in proper format as follows:

Pre Request for IM module:

``` 1. # sudo apt-get install python-gevent

2.# apt-get install psycogreen

3.# pip install psycogreen-1.0.tar.gz

  1. easy_install gevent

  2. easy_install greenlet

  3. apt-get install python-all-dev

7.# apt-get install libevent-dev

  1. easy_install gevent-psycopg2-0.0.3.tar.gz

  2. setup IM module

  3. And run your server by openerp-gevent

./server/openerp-gevent --addons addons/,web/addons &

  1. use port 8072 ```
Yashodhan Kulkarni
on 4/13/14, 7:22 PM

I am install python-gevent and install gevent_psycopg2

my openerp is version:

./openerp-server --version OpenERP Server 8.0dev-20140114-091614

but not start with --gevent parameter ?

show: ./openerp-server --gevent Usage: openerp-server [options]

openerp-server: error: no such option: --gevent

it has changed since I answered the question, now you have to launch the openerp not with openerp-server, but with a file called openerp-gevent, you need to launch the server with that, I will update my answer to add this, BTW: your post is not an answer, it is better suited to put it on a comment to the question or to a relevant answer.

on 1/15/14, 9:47 AM

What is the latest with this? I've tried the nightlies from 20140122 and 20140124 and there is no file called openerp-gevent.

A. Person
on 1/23/14, 9:55 PM

/usr/bin/openerp-gevent is installed if I patch setup.py like this: "scripts = ['openerp-server', 'openerp-gevent'],"

A. Person
on 1/27/14, 12:22 PM
febru wasono
On 9/2/13, 3:42 PM

go to openerp/tools/config.py

then set default value of gevent=True

then restart your server

see complete tutorial on febru dot soluvas dot com

Hi, I searched for the keyword gevent in config.py file, but i find no sign of it. can you please help with it.

komala kiran kumar. Parepalli
on 1/6/14, 2:06 AM

Ya, even I dont find any gevent = True / False;

Yashodhan Kulkarni
on 4/10/14, 7:40 AM
Alexis de Lattre
On 10/26/13, 9:31 PM

By the way, on OpenERP trunk, since October 5 2013, there is a script "openerp-gevent" next to the usual script "openerp-server". When you start "./openerp-gevent", it will run openerp on port 8072 in gevent/longpolling mode.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

7 follower(s)


Asked: 6/26/13, 4:17 AM
Seen: 14337 times
Last updated: 9/2/15, 4:58 AM