Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to access Odoo in a local Ubuntu server?

By
Luigi Sison
on 12/27/15, 2:21 PM 1,561 views

I installed Odoo 9 in an Ubuntu 14.04 Server (64-bit) in VirtualBox 5.010 in my PC. How do I access Odoo through my Chrome browser? I need this set-up so that I can demonstrate Odoo withouth a network connection. 

My IP address for eth0: 192.169.1.50

I tried http://localhost:8069 and http://192.169.1.50:8069 but they both don't work.

Also did the following:

Inside VM (called Ubuntu) changed the /etc/network/interfaces to a static IP 192.168.2.10

The interfaces file looks like this:

iface eth0 inet static

address 192.168.2.10

netmask 255.255.255.0

network 192.168.2.0

broadcast 192.168.2.255

gateway 192.168.2.1


Then, set up the host-only adapter as follows:

In File>Preferences>Network>Host-only Network Details, Adapter tab, set IPv4 Address to 192.168.2.1, IPv4Network Mask to 255.255.0.0

But, when I started the VM, I get this error:

Failed to open a session for the virtual machine Ubuntu.

Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter #2' (VERR_INTNET_FLT_IF_NOT_FOUND).

Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND).

Result Code: E_FAIL (0x80004005)

Component: ConsoleWrap

Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

1

Axel Mendoza

--Axel Mendoza--
10203
| 7 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 12/27/15, 4:06 PM

By default it's run on http://localhost:8069

the port part could vary depending of the configured port of your Odoo instance

0

gunnar

--gunnar--
1153
| 6 7 8
Germany
--gunnar--

born

gunnar
On 12/28/15, 3:12 AM

If I understand you correctly you want to acces the odoo interface in your hosting OS's chrome, right?

To me this looks like a network configuration problem of Virtual Box. In order to not go through a network you should put the network settings of VB to host-only adaptor. That should give you and IP address in a 192.158.56.xxx range. I think after you did that you might want to consider to setup a static IP (192.168.56.88 for example) for your Virtual machine that is hosting the odoo server, so you always find it under the same address.

  1. Inside Virtualbox select your VM > Settings >Network. Choose 'Host-only adapter' there

  2. Inside your VM change the /etc/network/interfaces to a static IP

  3. access odoo from your hosting OS's browser @ 192.168.56.88:8069 (assuming you have set the static IP of you ubuntu VM to 192.168.56.88.


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 12/27/15, 2:21 PM
Seen: 1561 times
Last updated: 12/28/15, 12:29 PM