Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How stop openerp to show Date deppending on local mechine time zone?

By
Rokon Uddin
on 9/29/14, 11:31 PM 878 views

In my Attendance module I import data from SQL Server Database of my Access Control Device to hr_attendace table of postgres. When I select attendance tab under Human Resource from GUI Date it show is actual time + my local mechine timezone. For example is my timezone is "+6" and actual date is 30/09/"2014 11:00:00" date filed shows 30/09/"2014 17:00:00". If I change locale mechine timezone to "+3", date field will show "30/09/"2014 14:00:00". How I can make openerp to show  Actual Date what are saved in hr_attendace table?

0

deep

--deep--
1617
| 5 4 7
Bengaluru, India
--deep--

Techno-Functional Associate with 6+ years of experience in Odoo (formerly known as OpenERP).

deep
On 9/30/14, 8:39 AM

Yes your observation is correct..

According to OperpERP, whatever date saved in database will be converted and saved in UTC format...

So, when Openerp retrieves the date(UTC) from database, it will again convert it to browse timezone (Local Time) ... which is correct in all aspects..

So  best option will be, the data which you have imported, update it to UTC format, then you need have to worry further about conversion..

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/29/14, 11:31 PM
Seen: 878 times
Last updated: 3/16/15, 8:10 AM