Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How people can register to odoo blog or forum modules without going to odoo?

By
Laurent
on 10/12/14, 9:27 AM 6,426 views

I have setup a server with odoo v8 and I am testing the odoo blog and forum modules. When I want to register as a fellow, I am redirected to the odoo.com domain, which is not acceptable nor professional nor respectful to my users since they want to register to my web site, not to odoo.com which appear as an alien.

Is it feasable without acking?

EDIT : additional information:

When I hover the Sign-in menu entry, I have: https://my-site.com/web/login
When I hover the register link, I have : https://my-site.com/web/signup
When I click the register link, it goes to : https://accounts.odoo.com/web/login?redirect=%2Foauth2%2Fauth%2F%3Fstate%3D%257B%2522p%2522%253A%2B1%252C%2B%2522r%2522%253A%2B%2522http%25253A%25252F%25252Fmy-site.com%25252Fweb%2522%252C%2B%2522d%2522%253A%2B%2522my-site%2522%257D%26redirect_uri%3Dhttp%253A%252F%252Fmy-site.com%252Fauth_oauth%252Fsignin%26response_type%3Dtoken%26client_id%3Dc57aad02-423d-11e4-98db-2fb386278206%26debug%3D1%26scope%3Duserinfo&mode=login&debug=1&scope=userinfo&login=&redirect_hostname=http%3A%2F%2Fmy-site.com

You can reach it here.

Hi Laurent, Any other deatils you can provide? Demo data This isn't installed right? You company details filled in? Whats the redirect say for U? on yours.. So i mouse over "Register Button" this is what i get. http://localhost:8069/web?redirect=http://localhost:8069/forum/help-1 Well without any more info it hard to say. Keep us informed of your discoveries... cheers

Vee
on 10/12/14, 9:42 AM

Hi Vee, I have added the links I have when I hover and when I click.

Laurent
on 10/12/14, 3:44 PM

@Laurent, Are you running on the hosted SaaS (ie. Odoo.com hosted), or a local install of Odoo (ie. on your own computer or server)? If you are running on a local install you can just uninstall the auth_oauth (OAuth2 Authentication) module, as this seems to redirect to Odoo.com for the signup. Then in order to allow external users to sign up you can go to Settings >> General Settings > Allow external users to sign up (just tick the box and then apply). This will create new users with the default 'Template User' access rights. If you want to create custom access rights you just need to create a user with the access rights you need and then use this in place of the Template User in General Settings.

Luke Branch
on 10/13/14, 1:37 AM

Auth module can be desactivated in Settings >> General Settings > Use tierce identification (my translation may not correspond to the original). It works, but I would have liked confirmation of signup by email. But this is another question.

Laurent
on 11/2/14, 1:29 PM

In addition, your solution disallows signup with facebook, twitter and google, which I would like to keep.

Laurent
on 11/2/14, 1:32 PM
3

Luke Branch

--Luke Branch--
1531
| 6 7 8
Mui Wo, Lantau, Hong Kong
--Luke Branch--

...

Luke Branch
On 11/3/14, 1:25 AM

@Laurent,

If you'd like to keep other OAuth providers but switch off Odoo.com signup you can just make sure that Settings >> General > Use external authentication providers, sign in with google, facebook, ... is ticked.

Then go to Settings >> OAuth Providers and find Odoo.com Accounts, click Edit and untick Allowed and save. This will allow you to add as many OAuth providers as you like for sign in, while keeping the Odoo.com default signup switched off.

You'll notice with Odoo.com Accounts OAuth method switched off you can go to yourdomain.com/web/signup and you'll have a standard (local) signup form. If you want to add other OAuth providers later you can do so.

If you have any issues with this (eg. after installation of another OAuth provider) please comment and explain the issues you have run into.

Looks great, but I don't have "Settings >> OAuth Providers". I have instead "Websites Settings" where I can precise my Twitter, Facebook, GitHub, LinkedIn, Youtube, Google+ Accounts, but not the Odoo one. I have a Git install positionned on release V8 dated September 18th, and commit #990d05e78dbac0bc8

Laurent
on 11/9/14, 4:09 AM

I have tried the last commit f3b3776128dca of November 7th. Still no "Settings >> OAuth Providers" nor "Odoo.com Accounts"

Laurent
on 11/9/14, 4:48 AM

Could you please precise your precise version, branch name, commit number?

Laurent
on 11/11/14, 3:38 AM

Hi Laurent, I update my development instance daily using the following steps: 0) BACKUP! Make sure your odoo filesystem and database is backed up before you make any changes. 1) sudo service odoo-server stop 2) sudo service postgresql stop 3) cd /opt/odoo/odoo-server 4) sudo git pull 5) sudo su odoo 6) cd /opt/odoo/odoo-server 7) ./openerp-server --update=all -c /etc/odoo-server.conf 8) .... wait a very long time for all modules in the database to update one by one until you can access the frontend of the website at your instances ip (eg. 192.168.1.100:8069) 9) Ctrl +C to cancel run of the openerp-server 10) exit (this will exit from the odoo user back to the normal user you logged in as) 11) sudo service postgresql start 12) sudo service odoo-server start If all goes well this should have updated your Odoo instance to the latest pull from github. In regards to not being able to see Settings >> OAuth Providers I think you may not have the 'Technical Settings' option ticked for your admin user. If it is un-ticked just tick it, save and then refresh the page and you should see a lot more technical features available for the admin user. Please also make sure you have Settings >> General Settings > Use external authentication providers, sign in with google, facebook ticked as well. Feel free to post back if you still can't see it.

Luke Branch
on 11/12/14, 4:12 AM
0

Ben Bernard

--Ben Bernard--
1083
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 10/13/14, 1:51 AM

I think you're using Odoo 8 beta / rc. This behaviour is removed in Odoo 8 stable. Please upgrade you code.

If you can't upgrade the code, try using disable_openerp_online (on branch 8.0) from this repo https://github.com/OCA/server-tools.

I am using branch 8.0, commit 990d05e78d tagged as [REL] Odoo 8.0. This is not beta as far as I can see. I tryed also the last commit 70b49a7608809 but the result is the same. Then I am going to try your solution.

Laurent
on 11/2/14, 1:54 PM
0
Vee
On 10/12/14, 10:56 PM

H Laurent, i think it's to do with Module - OAuth : (auth_oauth). Please look thru this module.

Found this: auth_oauth_data.xml

        <record id="provider_openerp" model="auth.oauth.provider">
            <field name="name">Odoo.com Accounts</field>
            <field name="auth_endpoint">https://accounts.odoo.com/oauth2/auth</field>
            <field name="scope">userinfo</field>
            <field name="validation_endpoint">https://accounts.odoo.com/oauth2/tokeninfo</field>
            <field name="data_endpoint"></field>
            <field name="css_class">zocial openerp</field>
            <field name="body">Log in with Odoo.com</field>
            <field name="enabled" eval="True"/>
        </record>

Now you could remove this and leave the other in place if still required.

Now, I could be wrong here check it out, i take no liability too.

Let us know how your go.  Cheers

Your solution does not work. I did suppress this record, then check with grep -Rl "accounts.odoo.com" I also commented the redirects inside addons/web/static/src/js/chrome.js Of course, I restarted odoo-server, suppressed browser cache, but I am still redirected to accounts.odoo.com

Laurent
on 11/2/14, 1:00 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

6 follower(s)

Stats

Asked: 10/12/14, 9:27 AM
Seen: 6426 times
Last updated: 7/18/16, 6:10 AM