Odoo Help

1

How is the default language for customers set?

By
dfor mer
on 9/30/13, 9:15 AM 1,911 views

I have read this question: How to set the default language for customers, suppliers?

But in my case, I use english as my default language and my assistant uses spanish as hers. 90% of our customers have spanish as their default however when I try to send an email, print a quote, order, invoice, etc they come out in english even though the language for the customer is spanish. When my assistant does the same they come out in spanish.

It is apparent that the system is choosing the user language over the customer language. Is this the correct behavior? If not, how can I correct it?

Regards

1
M. Höppner
On 10/1/13, 3:26 PM

I just wanted to give you an answer, however the same thing here. If I try to "print" something it chooses the correct language for the customer, set in the settings. However if I try to send an email - it's in English. And that even if in the email template (see settings -> email -> templates -> ... advanced tab) there is a line with: "${object.partner_id.lang}"

Hope it helps a bit in looking for the root cause

EDIT: the object above was not set in the template "Sales Order - Send by Email (Portal), when I add it => it work! just have a try ${object.partner_id.lang}

I appreciate your answer but in practice it doesn't work for me. It still chooses the logged in users default lang and not the partners lang. However when you go to the template and do a preview, it does choose the correct lang. Very strange and could be a bug

dfor mer
on 10/2/13, 3:36 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 9/30/13, 9:15 AM
Seen: 1911 times
Last updated: 3/16/15, 8:10 AM