Odoo Help

0

How do I make OpenERP use Postgres 9.2?

By
Bill Ennals
on 2/7/14, 7:04 PM 1,300 views

I have just upgraded PostgreSQL from 9.1 to 9.2 on Ubuntu 12.04 (OpenERP v7). I used this guide:

https://wiki.postgresql.org/wiki/Using_pg_upgrade_on_Ubuntu/Debian#Upgrading_to_version_9.2_or_later

and it seemed to work properly. I now have a separate 9.2 directory in /etc/postgresql along with the 9.1 directory.

My question is how do I configure OpenERP to use a particular version of PostgreSQL?

Bill.

1
Ralph LAvaud
On 2/7/14, 9:23 PM

Postgresql 9,2 is probably running on a different port. You need to get the port number from the postrgresql config file then modify your openerp config file to use the proper port.

Thanks Ralph. I think that worked. I made the changes you suggested, but after that the OpenERP database names seemed to get screwed up and trying to log into my development database kept resulting in an incorrect login error. I tried logging in with admin/admin and that worked, but the database it was logging me into was another one that I had created with just the demo data in it. I had done a full backup of the development database before upgrading PostgreSQL so I dropped all the existing databases and restored the backup. I could then log in to it as normal.

Bill Ennals
on 2/15/14, 12:03 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)

Stats

Asked: 2/7/14, 7:04 PM
Seen: 1300 times
Last updated: 3/16/15, 8:10 AM