Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How can i inherit a view setting-> Configuration -> Accounting?

By
samba
on 7/28/14, 10:55 AM 622 views

I have inherit this  Settings-> Configuration -> Accounting. I have added one check box. when i mark this check box to true, after click on "apply" button, this check box showing like uncheked check box. But the value storing in database is "True".

I would get the field to that menu. But the value supplied to that field not showing properly. for example i have added a field "vattaxrateinvoice" and added value "10%" after click on "apply" button, the field vattaxrateinvoice not showing "10%". It is showing blank. But the value "10%" store in database perfectly

0
Juan José Scarafía
On 7/30/14, 8:28 AM

Hi samba,

About what you're asking, you can see an example here: https://github.com/ingadhoc/odoo-addons/blob/master/account_voucher_receipt/res_config_view.xml

Regards,

Juan José - Ing ADHOC

Thank you jaun, I would get the field to that menu. But the value supplied to that field not showing properly. for example i have added a field "vattaxrateinvoice" and added value "10%" after click on "apply" button, the field vattaxrateinvoice not showing "10%". It is showing blank. But the value "10%" store in database perfectly

samba
on 7/30/14, 9:08 AM
I think that you should define the function that get the default value. If I have "my_config_field" then I should also have "get_default_get_default_virtual_alias_path" and "set_get_default_virtual_alias_path". 
I think it works like this but of course I can be wrong. 

Ing. Juan José Scarafía
(+54 9 341)153 278039
skype: jjscarafia
twitter: @jjscarafia
github: @jjscarafia



2014-07-30 10:08 GMT-03:00 samba <gs9783@gmail.com>:

Thank you jaun, I would get the field to that menu. But the value supplied to that field not showing properly. for example i have added a field "vattaxrateinvoice" and added value "10%" after click on "apply" button, the field vattaxrateinvoice not showing "10%". It is showing blank. But the value "10%" store in database perfectly

--
samba Sent by OpenERP S.A. using Odoo. Access your messages and documents in Odoo

Juan José Scarafía
on 7/30/14, 10:29 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 7/28/14, 10:55 AM
Seen: 622 times
Last updated: 3/16/15, 8:10 AM