Odoo Help

3

1
21 Answers
10
Avatar

Yenthe Van Ginneken Belgium

--Yenthe Van Ginneken--
25118
| 9 9 12
Turnhout, Belgium
--Yenthe Van Ginneken--


Yenthe Van Ginneken Belgium
10/7/17, 12:53 PM

Odoo can be found on Github, you can find Odoo 11 here
You can find the official downloads (for Windows, Debian, RPM and the sources) at https://www.odoo.com/page/download
To install it on Ubuntu you can follow the following steps:

1. Download my installation script from Github and copy it locally:

sudo wget https://raw.githubusercontent.com/Yenthe666/InstallScript/11.0/odoo_install.sh

2. Edit the file and modify the parameters that you'd like to change:

sudo nano odoo_install.sh

Tip: If you'd like the enterprise version you should set IS_ENTERPRISE to True instead of false.
3. Make the file executable:

sudo chmod +x odoo_install.sh

4. Execute the script and wait a few minutes for Odoo to install:

./odoo_install.sh


Regards,
Yenthe

7 Comments
Abdullah Aljelaify Saudi Arabia
10/8/17, 6:47 PM

First of all Thanks for this short guide it's the only thing that worked

problem is after installing and opening the odoo page i get the create db page but with no CSS what so ever the only thing i changed in the installation script is Enterprise = True

so can you tell me if i had to change something else? did i miss something

Thanks

Oocademy, Yenthe Van Ginneken Belgium
10/9/17, 3:09 AM

This has to do with the less (the Odoo assets) that are not compiling. There are a few problems with this (such as on V9 & V10 https://github.com/odoo/odoo/issues/19627). If you do a -u all of your database it is usually fixed.

Abdullah Aljelaify Saudi Arabia
10/9/17, 10:19 AM

The URL doesn't work for github

can you give me more details about how to do the -u

i am new to ubuntu :(

Oocademy, Yenthe Van Ginneken Belgium
10/9/17, 11:08 AM

1. cd /odoo/odoo-server

2. sudo service odoo-server stop

3. sudo su odoo

4. ./odoo-bin -u all -c /etc/your-odoo-server.conf

Abdullah Aljelaify Saudi Arabia
10/9/17, 5:34 PM

Thanks man

Finally something that works !!

its up and running

after executing the last command the terminal didn't do anything or show anything it looked like it's waiting for a response or something than after waiting to long i restarted the server and it worked

Thanks man

Abdullah Aljelaify Saudi Arabia
10/9/17, 5:55 PM

Sorry

i think i have made a mistake i checked and it looks like it's the same issue nothing happened apperntly i have checked the wrong server and thought it was fixed

so what should i do than i have also checked the server log and it's full do you need me to copy that here to see whats the problem

please note that this is a fresh off the box install for ubuntu

Abdullah Aljelaify Saudi Arabia
10/9/17, 6:24 PM

Ok CE works

the problem is in installing Enterprise doesn't work with this script i think

i have another question where is Accounting module in odoo11 ? can't find it

0
Ben Beattie Australia
6/14/18, 7:09 PM

Hi, I also need some help.

I am trying to install enterprise on a Bitnami LAMP stack (stripped down debian)

I followed the instructions and it installed fine, I ran - all on my .conf file as above however I get this error

  File "/usr/lib/python3.5/socketserver.py", line 454, in server_bind

    self.socket.bind(self.server_address)

OSError: [Errno 98] Address already in use


2018-06-15 09:23:59,384 11054 INFO ? odoo.addons.base.ir.ir_actions_report: You need Wkhtmltopdf to print a pdf version of the reports.


Do I need that to go further?

Localhost:8069 just times out.

Any help appreciated.


0
Sebastián Di Luise Argentina
12/22/17, 7:42 PM

Thanks! the script works flawless.  Ran on an Ubuntu 16.04.3 virtualboxed updated with nothing else installed.

0
Hakim Madi France
10/17/17, 2:05 PM

Hi,


I installed Odoo 11 with the odoo-install.sh script of Yenthe and it works well. I also have an issue to configure m'y website redirection from http to https port 8069.

I tried To configure it with apache2 folder etc/apache2/sites-available/ but it only redirect http to https and not working on port 8069.


Thank you for help.

0
Peido Canada
10/16/17, 7:04 AM

Hello guys, after installing odoo 11 community on Ubuntu, i am getting connection refused on the web interface.

Please let me know if someone has see this issue


Thanks.

0
comceptPLUS GmbH Germany
10/12/17, 12:26 PM

Hi guys, I have the same issue as

Abdullah Aljelaify

I installed odoo 11 EE with the script but have only a screen that is without css. I dont the the function -u all to work. The server does nothing then. Any help so far? 

Thanks a lot! 
2 Comments
Oocademy, Yenthe Van Ginneken Belgium
10/12/17, 12:57 PM

Please do report it at https://github.com/Yenthe666/InstallScript/issues (add as much info as you can please. For example the OS and parts of the logfile.)

comceptPLUS GmbH Germany
10/12/17, 1:02 PM

Hi yente, thanks for you fast response. did it directly. If you need any more information, please tell me. thanks a lot.

0
Odoo For Beginners Morocco
10/11/17, 11:36 AM

Hello everyone,

You will find here how to install odoo11 community in simple way:

https://odooforbeginnersblog.wordpress.com/2017/10/11/how-to-install-odoo11-community-version/

0
Webkul India
10/9/17, 8:26 AM

Check it out : 

https://webkul.com/blog/install-odoo11-on-ubuntu

2 Comments
Abdullah Aljelaify Saudi Arabia
10/9/17, 10:17 AM

i tried this it didn't work with me

Oocademy, Yenthe Van Ginneken Belgium
10/9/17, 11:06 AM

Manually running all commands is so not fun? ;-)

0
Alpha China
10/7/17, 2:21 PM

On windows7?

1 Comment
Oocademy, Yenthe Van Ginneken Belgium
10/9/17, 3:08 AM

You can download the official installer (.exe file) from https://www.odoo.com/page/download to install on Windows.

Ask a Question
Keep Informed
4 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now